summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorph10 <ph10@6239d852-aaf2-0410-a92c-79f79f948069>2014-08-16 09:46:58 +0000
committerph10 <ph10@6239d852-aaf2-0410-a92c-79f79f948069>2014-08-16 09:46:58 +0000
commit258ffeb078daec58f94e67b872a1e391bc714529 (patch)
treea593807360f583bdeaf95fcc00696a3c5cc104c7 /configure.ac
parent976b57b7349675feac40d0c761e75b4379e14486 (diff)
downloadpcre2-258ffeb078daec58f94e67b872a1e391bc714529.tar.gz
Change lengths to PCRE2_SIZE and revise OP_RECURSE processing.
git-svn-id: svn://vcs.exim.org/pcre2/code/trunk@57 6239d852-aaf2-0410-a92c-79f79f948069
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 3130962..167d3b8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -523,10 +523,10 @@ if test "$enable_utf" = "yes"; then
fi
if test "$enable_stack_for_recursion" = "no"; then
- AC_DEFINE([NO_RECURSE], [], [
+ AC_DEFINE([HEAP_MATCH_RECURSE], [], [
PCRE2 uses recursive function calls to handle backtracking while
matching. This can sometimes be a problem on systems that have
- stacks of limited size. Define NO_RECURSE to any value to get a
+ stacks of limited size. Define HEAP_MATCH_RECURSE to any value to get a
version that doesn't use recursion in the match() function; instead
it creates its own stack by steam using memory from the heap. For more
detail, see the comments and other stuff just above the match() function.])
@@ -608,7 +608,7 @@ AC_DEFINE_UNQUOTED([MATCH_LIMIT_RECURSION], [$with_match_limit_recursion], [
increase the recursion depth. In some environments it is desirable
to limit the depth of recursive calls of match() more strictly, in
order to restrict the maximum amount of stack (or heap, if
- NO_RECURSE is defined) that is used. The value of
+ HEAP_MATCH_RECURSE is defined) that is used. The value of
MATCH_LIMIT_RECURSION applies only to recursive calls of match(). To
have any useful effect, it must be less than the value of
MATCH_LIMIT. The default is to use the same value as MATCH_LIMIT.