summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorph10 <ph10@6239d852-aaf2-0410-a92c-79f79f948069>2016-12-31 17:40:45 +0000
committerph10 <ph10@6239d852-aaf2-0410-a92c-79f79f948069>2016-12-31 17:40:45 +0000
commit9c63b32be361e637bf9797d66dc5995b5451809c (patch)
tree42a02a700dea948ed3a5f4e0aba49ca604523e5c /configure.ac
parent5b4ac7bf2c9fb6428c9609020b1ac2d2f58b1421 (diff)
downloadpcre2-9c63b32be361e637bf9797d66dc5995b5451809c.tar.gz
Upgrade pcre2grep for Windows courtesy of Jason Hood.
git-svn-id: svn://vcs.exim.org/pcre2/code/trunk@640 6239d852-aaf2-0410-a92c-79f79f948069
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 7 insertions, 17 deletions
diff --git a/configure.ac b/configure.ac
index fc5cea2..7b62d7f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -148,16 +148,11 @@ AC_ARG_ENABLE(pcre2grep-jit,
[disable JIT support in pcre2grep]),
, enable_pcre2grep_jit=yes)
-# Handle --disable-pcre2grep-callout (enabled by default) but not supported
-# for Windows.
-if test "$HAVE_WINDOWS_H" != "1"; then
- AC_ARG_ENABLE(pcre2grep-callout,
- AS_HELP_STRING([--disable-pcre2grep-callout],
- [disable callout script support in pcre2grep]),
- , enable_pcre2grep_callout=yes)
-else
- enable_pcre2grep_callout=no
-fi
+# Handle --disable-pcre2grep-callout (enabled by default)
+AC_ARG_ENABLE(pcre2grep-callout,
+ AS_HELP_STRING([--disable-pcre2grep-callout],
+ [disable callout script support in pcre2grep]),
+ , enable_pcre2grep_callout=yes)
# Handle --enable-rebuild-chartables
AC_ARG_ENABLE(rebuild-chartables,
@@ -577,19 +572,14 @@ if test "$enable_pcre2grep_jit" = "yes"; then
have no effect unless SUPPORT_JIT is also defined.])
fi
-# Currently pcre2grep callout string is not supported under Windows.
-
if test "$enable_pcre2grep_callout" = "yes"; then
if test "$HAVE_WINDOWS_H" != "1"; then
if test "$HAVE_SYS_WAIT_H" != "1"; then
AC_MSG_ERROR([Callout script support needs sys/wait.h.])
fi
- AC_DEFINE([SUPPORT_PCRE2GREP_CALLOUT], [], [
- Define to any value to enable callout script support in pcre2grep.])
- else
- AC_MSG_WARN([Callout script support is not available for Windows: disabled])
- enable_pcre2grep_callout=no
fi
+ AC_DEFINE([SUPPORT_PCRE2GREP_CALLOUT], [], [
+ Define to any value to enable callout script support in pcre2grep.])
fi
if test "$enable_unicode" = "yes"; then