summaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL16
1 files changed, 16 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
new file mode 100644
index 0000000..0821dde
--- /dev/null
+++ b/Makefile.PL
@@ -0,0 +1,16 @@
+use ExtUtils::MakeMaker;
+# See lib/ExtUtils/MakeMaker.pm for details of how to influence
+# the contents of the Makefile that is written.
+
+require 5.005;
+
+WriteMakefile(
+ 'NAME' => 'XML::XPath',
+ 'VERSION_FROM' => 'XPath.pm', # finds $VERSION
+ 'AUTHOR' => 'Matt Sergeant, AxKit.com Ltd',
+ 'ABSTRACT_FROM' => 'XPath.pm',
+ 'PREREQ_PM' => {
+ 'XML::Parser' => '2.23',
+ },
+ 'EXE_FILES' => [ 'examples/xpath' ],
+);