summaryrefslogtreecommitdiff
path: root/cpan/libnet/Makefile.PL
diff options
context:
space:
mode:
authorChris 'BinGOs' Williams <chris@bingosnet.co.uk>2014-10-10 13:37:54 +0100
committerChris 'BinGOs' Williams <chris@bingosnet.co.uk>2014-10-10 13:37:54 +0100
commit2e1731446cd265cddae2ea6c43a375168fdb6f56 (patch)
treec33cc53619505c4ab6776a0dad9c5e3eef9470c1 /cpan/libnet/Makefile.PL
parent81edd47dd21ee48a12c2a596d7ee64c9cbff0754 (diff)
downloadperl-2e1731446cd265cddae2ea6c43a375168fdb6f56.tar.gz
Update libnet to CPAN version 3.01
[DELTA] libnet 3.01 -- Thu Oct 09 2014 * Require IO::Socket::SSL >= 1.999 to protect against a bad version (0.30) of IO::Socket::IP and hopefully fix another bunch of CPAN Testers failures. libnet 3.00 -- Thu Oct 09 2014 * Skip Perl Critic, Pod and Pod Coverage tests unless AUTHOR_TESTING. [Resolves CPAN RT#99399] * Synchronize all $VERSIONs to the distribution's version number, bumping that to 3.00 so that no $VERSIONs end up going backwards. libnet 1.30 -- Wed Oct 08 2014 * Sigh. Fix PAUSE indexing problem again. Net::SMTP::SSL is already used by Net-SMTP-SSL. libnet 1.29 -- Wed Oct 08 2014 * Fix PAUSE indexing problem. Net::POP3::_SSLified and Net::SMTP::_SSLified are already used by Net-SSLGlue. libnet 1.28 -- Wed Oct 08 2014 * Improve code()/message() initialization and error handling in Net::Cmd [Tom Metro; resolves CPAN RT#14875] * Don't use the ALLO command on FTP servers that don't support it. [Resolves CPAN RT#95717] * Stop Makefile.PL from requiring interactive configuration when running via cpan, cpanp or cpanm: just accept all defaults in these cases, as when running non-interactively. [Resolves CPAN RT#48966] * Add optional POD coverage testing. * Add optional POD testing. * Add optional Perl::Critic testing. * Make code Perl::Critic clean. * Move Net/*.pm into lib/Net/ sub-directory within distribution. This is the usual layout style these days. * Change Net::SMTP::auth() so that it now falls back to another supported AUTH method if a given AUTH method fails. [Ivan Baktsheev; closes PR#3] * Change Net::SMTP::auth() so that it uses the SMTP AUTH mechanism(s) specified in the Authen::SASL object if one is provided instead of a username. If a plain text username is specified then use the first reported SMTP AUTH method supported, as usual. [Ewen McNeill; resolves CPAN RT#58002] * Add support for IPv6 and SSL to Net::FTP, Net::NNTP, Net::POP3 and Net::SMTP. These features are only available if the user has a recent IO::Socket::SSL for SSL support a recent IO::Socket::IP or an older IO::Socket::INET6 for IPv6 support If no SSL module is available it will work as before, but attempts to use the SSL functionality will result in an error message. If no IPv6 modules are available it will just use IPv4 as before. With IPv6 modules installed one can of course still access IPv4 hosts. [Steffen Ullrich; resolves CPAN RT#93823]
Diffstat (limited to 'cpan/libnet/Makefile.PL')
-rw-r--r--cpan/libnet/Makefile.PL104
1 files changed, 101 insertions, 3 deletions
diff --git a/cpan/libnet/Makefile.PL b/cpan/libnet/Makefile.PL
index 7e21e3c61c..30bbd73b9e 100644
--- a/cpan/libnet/Makefile.PL
+++ b/cpan/libnet/Makefile.PL
@@ -23,6 +23,10 @@ use warnings;
use ExtUtils::MakeMaker 6.64;
use ExtUtils::MakeMaker qw(WriteMakefile);
+## no critic (Subroutines::ProhibitSubroutinePrototypes)
+
+sub running_under_cpan();
+
#===============================================================================
# INITIALIZATION
#===============================================================================
@@ -42,13 +46,25 @@ MAIN: {
my %prereq_pms = ();
$prereq_pms{'Convert::EBCDIC'} = '0.06' if $^O eq 'os390';
+ my $xt = 'n';
+ if (not running_under_cpan()) {
+ $xt = prompt("Should I do external tests?\n" .
+ "These tests will fail if there is no internet" .
+ " connection or if a firewall\n" .
+ "blocks or modifies some traffic.\n" .
+ "[y/N]", 'n');
+ }
+
+ my $tests = 't/*.t';
+ $tests .= ' t/external/*.t' if $xt =~ m/^y/io;
+
WriteMakefile(
NAME => 'Net',
DISTNAME => 'libnet',
ABSTRACT => 'Collection of network protocol modules',
AUTHOR => 'Graham Barr <gbarr@pobox.com>, Steve Hay <shay@cpan.org>',
LICENSE => 'perl_5',
- VERSION => '1.27',
+ VERSION => '3.01',
META_MERGE => {
'meta-spec' => {
@@ -84,6 +100,62 @@ MAIN: {
}
}
}
+ },
+
+ SSL => {
+ description => 'SSL support',
+ prereqs => {
+ runtime => {
+ requires => {
+ 'IO::Socket::SSL' => '1.999'
+ }
+ }
+ }
+ },
+
+ IPv6 => {
+ description => 'IPv6 support',
+ prereqs => {
+ runtime => {
+ requires => {
+ 'IO::Socket::IP' => '0.20'
+ # or IO::Socket::INET6 2.62
+ }
+ }
+ }
+ },
+
+ critictest => {
+ description => 'Perl::Critic testing',
+ prereqs => {
+ test => {
+ requires => {
+ 'Test::Perl::Critic' => '0'
+ }
+ }
+ }
+ },
+
+ podtest => {
+ description => 'POD testing',
+ prereqs => {
+ test => {
+ requires => {
+ 'Test::Pod' => '1.00'
+ }
+ }
+ }
+ },
+
+ podcoveragetest => {
+ description => 'POD coverage testing',
+ prereqs => {
+ test => {
+ requires => {
+ 'Test::Pod::Coverage' => '0.08'
+ }
+ }
+ }
}
}
},
@@ -101,7 +173,8 @@ MAIN: {
},
TEST_REQUIRES => {
- 'Cwd' => '0'
+ 'Config' => '0',
+ 'Cwd' => '0'
},
PREREQ_PM => {
@@ -118,6 +191,7 @@ MAIN: {
'Socket' => '1.3',
'Symbol' => '0',
'Time::Local' => '0',
+ 'constant' => '0',
'strict' => '0',
'vars' => '0'
},
@@ -128,6 +202,10 @@ MAIN: {
FILES => $CfgFile
},
+ test => {
+ TESTS => $tests
+ },
+
dist => {
PREOP => 'find $(DISTVNAME) -type d -print|xargs chmod 0755 && ' .
'find $(DISTVNAME) -type f -print|xargs chmod 0644',
@@ -142,10 +220,30 @@ MAIN: {
sub MY::post_initialize {
my $self = shift;
+
return '' if $self->{PERL_CORE};
- system(($^O eq 'VMS' ? 'mcr ': ()), $^X, 'Configure') unless -f $CfgFile;
+
+ if (not -f $CfgFile) {
+ my @args = qw(Configure);
+ push @args, '-d' if $ENV{PERL5_CPAN_IS_RUNNING} ||
+ $ENV{PERL5_CPANPLUS_IS_RUNNING} ||
+ $ENV{PERL5_CPANM_IS_RUNNING};
+ system(($^O eq 'VMS' ? 'mcr ': ()), $^X, @args)
+ }
+
$self->{PM}{$CfgFile} = $self->catfile('$(INST_LIBDIR)',$CfgPath);
+
return '';
}
#===============================================================================
+# SUBROUTINES
+#===============================================================================
+
+sub running_under_cpan() {
+ return $ENV{PERL5_CPAN_IS_RUNNING} || # cpan
+ $ENV{PERL5_CPANPLUS_IS_RUNNING} || # cpanp
+ $ENV{PERL5_CPANM_IS_RUNNING}; # cpanm
+}
+
+#===============================================================================