summaryrefslogtreecommitdiff
path: root/ext/IO_Compress_Zlib/Makefile.PL
diff options
context:
space:
mode:
authorCraig A. Berry <craigberry@mac.com>2007-04-24 03:18:34 +0000
committerCraig A. Berry <craigberry@mac.com>2007-04-24 03:18:34 +0000
commit1e6aeec812b843a7ede56e2466b96a7284b7f423 (patch)
treedf44b9478e2bbf66164cf612bd2d2f2c62910fe8 /ext/IO_Compress_Zlib/Makefile.PL
parent009d90df4e17a4157d8fe825678a18dc3e97d437 (diff)
downloadperl-1e6aeec812b843a7ede56e2466b96a7284b7f423.tar.gz
Reduce directory depth for IO::Compress modules.
p4raw-id: //depot/perl@31047
Diffstat (limited to 'ext/IO_Compress_Zlib/Makefile.PL')
-rw-r--r--ext/IO_Compress_Zlib/Makefile.PL48
1 files changed, 48 insertions, 0 deletions
diff --git a/ext/IO_Compress_Zlib/Makefile.PL b/ext/IO_Compress_Zlib/Makefile.PL
new file mode 100644
index 0000000000..4d38fc7fa9
--- /dev/null
+++ b/ext/IO_Compress_Zlib/Makefile.PL
@@ -0,0 +1,48 @@
+#! perl -w
+
+use strict ;
+require 5.004 ;
+
+$::VERSION = '2.004' ;
+
+use private::MakeUtil;
+use ExtUtils::MakeMaker 5.16 ;
+
+UpDowngrade(getPerlFiles('MANIFEST'))
+ unless $ENV{PERL_CORE};
+
+WriteMakefile(
+ NAME => 'IO::Compress::Zlib',
+ VERSION_FROM => 'lib/IO/Compress/Gzip.pm',
+ 'dist' => { COMPRESS => 'gzip',
+ TARFLAGS => '-chvf',
+ SUFFIX => 'gz',
+ DIST_DEFAULT => 'MyTrebleCheck tardist',
+ },
+
+ (
+ $ENV{SKIP_FOR_CORE}
+ ? (MAN3PODS => {})
+ : (PREREQ_PM => { 'Compress::Raw::Zlib' => $::VERSION,
+ 'IO::Compress::Base' => $::VERSION,
+ 'IO::Uncompress::Base' => $::VERSION,
+ $] >= 5.005 && $] < 5.006
+ ? ('File::BSDGlob' => 0)
+ : () }
+ )
+ ),
+
+ (
+ $] >= 5.005
+ ? (ABSTRACT => 'Perl interface to zlib',
+ AUTHOR => 'Paul Marquess <pmqs@cpan.org>')
+ : ()
+ ),
+
+ ((ExtUtils::MakeMaker->VERSION() gt '6.30') ?
+ ('LICENSE' => 'perl') : ()),
+
+) ;
+
+# end of file Makefile.PL
+