summaryrefslogtreecommitdiff
path: root/ext/XS-APItest/Makefile.PL
diff options
context:
space:
mode:
authorNicholas Clark <nick@ccl4.org>2010-09-21 14:07:00 +0100
committerNicholas Clark <nick@ccl4.org>2010-09-21 14:07:00 +0100
commit8c5ae9a317f870fc7f907bff15be2ed3bcb7b7a4 (patch)
tree429ffb7e577a26c445a3b60fc2f335f9f4934a8b /ext/XS-APItest/Makefile.PL
parente2f1cb345b8e60b81ce9f8a291b2fc77b7e21c85 (diff)
downloadperl-8c5ae9a317f870fc7f907bff15be2ed3bcb7b7a4.tar.gz
Remove boilerplate and (un)conditional code from Makefile.PLs in ext
Diffstat (limited to 'ext/XS-APItest/Makefile.PL')
-rw-r--r--ext/XS-APItest/Makefile.PL12
1 files changed, 2 insertions, 10 deletions
diff --git a/ext/XS-APItest/Makefile.PL b/ext/XS-APItest/Makefile.PL
index 9b76a2919d..bccf38fef8 100644
--- a/ext/XS-APItest/Makefile.PL
+++ b/ext/XS-APItest/Makefile.PL
@@ -3,22 +3,14 @@ use ExtUtils::MakeMaker;
use ExtUtils::Constant 0.11 'WriteConstants';
use Config;
-# See lib/ExtUtils/MakeMaker.pm for details of how to influence
-# the contents of the Makefile that is written.
WriteMakefile(
'NAME' => 'XS::APItest',
'VERSION_FROM' => 'APItest.pm', # finds $VERSION
'PREREQ_PM' => {}, # e.g., Module::Name => 1.1
- ($] >= 5.005 ? ## Add these new keywords supported since 5.005
- (ABSTRACT_FROM => 'APItest.pm', # retrieve abstract from module
- AUTHOR => 'Tim Jenness <t.jenness@jach.hawaii.edu>, Christian Soeller <csoelle@mph.auckland.ac.nz>, Hugo van der Sanden <hv@crypt.compulink.co.uk>') : ()),
+ ABSTRACT_FROM => 'APItest.pm', # retrieve abstract from module
+ AUTHOR => 'Tim Jenness <t.jenness@jach.hawaii.edu>, Christian Soeller <csoelle@mph.auckland.ac.nz>, Hugo van der Sanden <hv@crypt.compulink.co.uk>',
'C' => ['exception.c', 'core.c', 'notcore.c'],
'OBJECT' => '$(BASEEXT)$(OBJ_EXT) $(O_FILES)',
- 'LIBS' => [''], # e.g., '-lm'
- 'DEFINE' => '', # e.g., '-DHAVE_SOMETHING'
- 'INC' => '-I.', # e.g., '-I. -I/usr/include/other'
- # Un-comment this if you add C files to link with later:
- # 'OBJECT' => '$(O_FILES)', # link all the C files too
realclean => {FILES => 'const-c.inc const-xs.inc'},
($Config{gccversion} && $Config{d_attribute_deprecated} ?
(CCFLAGS => $Config{ccflags} . ' -Wno-deprecated-declarations') : ()),