summaryrefslogtreecommitdiff
path: root/dist/Math-Complex/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'dist/Math-Complex/Makefile.PL')
-rw-r--r--dist/Math-Complex/Makefile.PL22
1 files changed, 22 insertions, 0 deletions
diff --git a/dist/Math-Complex/Makefile.PL b/dist/Math-Complex/Makefile.PL
new file mode 100644
index 0000000000..5b95eb47bc
--- /dev/null
+++ b/dist/Math-Complex/Makefile.PL
@@ -0,0 +1,22 @@
+{ use 5.006; }
+
+use ExtUtils::MakeMaker;
+
+WriteMakefile(
+ NAME => 'Math::Complex',
+ VERSION_FROM => 'lib/Math/Complex.pm',
+ INSTALLDIRS => ( $] < 5.011 ? 'perl' : 'site' ),
+ PREREQ_PM =>
+ {
+ 'Config' => 0,
+ 'Exporter' => 0,
+ 'ExtUtils::MakeMaker' => 0,
+ 'Scalar::Util' => '1.11',
+ 'Test::More' => 0,
+ 'overload' => 0,
+ 'strict' => 0,
+ 'warnings' => 0,
+ },
+ ($ExtUtils::MakeMaker::VERSION >= 6.3002 ?
+ ('LICENSE'=> 'perl_5', ) : ()),
+ );