summaryrefslogtreecommitdiff
path: root/ext/Encode/JP/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'ext/Encode/JP/Makefile.PL')
-rw-r--r--ext/Encode/JP/Makefile.PL16
1 files changed, 8 insertions, 8 deletions
diff --git a/ext/Encode/JP/Makefile.PL b/ext/Encode/JP/Makefile.PL
index 69235debbe..5ce6ef6b66 100644
--- a/ext/Encode/JP/Makefile.PL
+++ b/ext/Encode/JP/Makefile.PL
@@ -12,7 +12,7 @@ my %tables = (
my $name = 'JP';
WriteMakefile(
- INC => "-I..",
+ INC => "-I../Encode",
NAME => 'Encode::'.$name,
VERSION_FROM => "$name.pm",
OBJECT => '$(O_FILES)',
@@ -42,7 +42,7 @@ sub post_initialize
$self->{'O_FILES'} = [sort keys %o];
my @files = ("$name.xs");
$self->{'C'} = ["$name.c"];
- $self->{'H'} = [$self->catfile($self->updir,'encode.h')];
+ $self->{'H'} = [$self->catfile($self->updir,'Encode', 'encode.h')];
my %xs;
foreach my $table (keys %tables) {
push (@{$self->{'C'}},"$table.c");
@@ -60,7 +60,7 @@ sub post_initialize
#include <perl.h>
#include <XSUB.h>
#define U8 U8
-#include "../encode.h"
+#include "encode.h"
END
foreach my $table (keys %tables) {
print XS qq[#include "${table}.h"\n];
@@ -103,7 +103,7 @@ sub postamble
{
my $self = shift;
my $dir = $self->catdir($self->updir,'Encode');
- my $str = "# $name\$(OBJ_EXT) depends on .h and _def.h files not .c files - but all written by compile\n";
+ my $str = "# $name\$(OBJ_EXT) depends on .h and _def.h files not .c files - but all written by enc2xs\n";
$str .= "$name.c : $name.xs ";
foreach my $table (keys %tables)
{
@@ -112,13 +112,13 @@ sub postamble
$str .= "\n\n";
$str .= "$name\$(OBJ_EXT) : $name.c\n\n";
- my $compile = $self->catfile($self->updir,'compile');
+ my $enc2xs = $self->catfile($self->updir,'bin', 'enc2xs');
foreach my $table (keys %tables)
{
my $numlines = 1;
my $lengthsofar = length($str);
my $continuator = '';
- $str .= "$table.c : $compile Makefile.PL";
+ $str .= "$table.c : $enc2xs Makefile.PL";
foreach my $file (@{$tables{$table}})
{
$str .= $continuator.' '.$self->catfile($dir,$file);
@@ -131,8 +131,8 @@ sub postamble
}
}
$str .= $^O eq 'VMS' # In VMS quote to preserve case
- ? qq{\n\t\$(PERL) $compile -"Q" -o \$\@ -f $table.fnm\n\n}
- : qq{\n\t\$(PERL) $compile -Q -o \$\@ -f $table.fnm\n\n};
+ ? qq{\n\t\$(PERL) $enc2xs -"Q" -o \$\@ -f $table.fnm\n\n}
+ : qq{\n\t\$(PERL) $enc2xs -Q -o \$\@ -f $table.fnm\n\n};
open (FILELIST, ">$table.fnm")
|| die "Could not open $table.fnm: $!";
foreach my $file (@{$tables{$table}})