summaryrefslogtreecommitdiff
path: root/ext/SDBM_File/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'ext/SDBM_File/Makefile.PL')
-rw-r--r--ext/SDBM_File/Makefile.PL5
1 files changed, 4 insertions, 1 deletions
diff --git a/ext/SDBM_File/Makefile.PL b/ext/SDBM_File/Makefile.PL
index 8fc9411768..210879f90b 100644
--- a/ext/SDBM_File/Makefile.PL
+++ b/ext/SDBM_File/Makefile.PL
@@ -5,19 +5,22 @@ use ExtUtils::MakeMaker;
# config, all, clean, realclean and sdbm/Makefile
# which perform the corresponding actions in the subdirectory.
+$define = ($^O eq 'MSWin32') ? '/D "MSDOS"' : '';
+
WriteMakefile(
NAME => 'SDBM_File',
MYEXTLIB => 'sdbm/libsdbm$(LIB_EXT)',
MAN3PODS => ' ', # Pods will be built by installman.
XSPROTOARG => '-noprototypes', # XXX remove later?
VERSION_FROM => 'SDBM_File.pm',
+ DEFINE => $define,
);
sub MY::postamble {
'
$(MYEXTLIB): sdbm/Makefile
- cd sdbm; $(MAKE) all
+ cd sdbm && $(MAKE) all
';
}