summaryrefslogtreecommitdiff
path: root/haiku/Haiku/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'haiku/Haiku/Makefile.PL')
-rw-r--r--haiku/Haiku/Makefile.PL20
1 files changed, 20 insertions, 0 deletions
diff --git a/haiku/Haiku/Makefile.PL b/haiku/Haiku/Makefile.PL
new file mode 100644
index 0000000000..dacf230201
--- /dev/null
+++ b/haiku/Haiku/Makefile.PL
@@ -0,0 +1,20 @@
+use 5.006;
+use ExtUtils::MakeMaker;
+
+unless ($^O eq "haiku") {
+ die "OS unsupported\n";
+}
+
+#my @libs;
+#push @libs, '-L/lib/w32api -lole32 -lversion' if $^O eq "cygwin";
+
+WriteMakefile(
+ NAME => 'Haiku',
+ VERSION_FROM => 'Haiku.pm',
+# LIBS => \@libs,
+ INSTALLDIRS => ($] >= 5.008004 ? 'perl' : 'site'),
+ NO_META => 1,
+
+ AUTHOR => 'Ingo Weinhold <ingo_weinhold@gmx.de>',
+ ABSTRACT_FROM => 'Haiku.pm',
+);