summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorThomas Kluyver <takowl@gmail.com>2013-09-17 10:59:32 -0700
committerThomas Kluyver <takowl@gmail.com>2013-09-17 10:59:32 -0700
commit3349aba986ec86bada083103491b1597eb7bbfb5 (patch)
tree74b80cbc0e9d34974d777cb4f39adfbd14386d91 /setup.py
parent73e7afd0f9b7410b390260f24c6efec7c5212a04 (diff)
downloadpexpect-git-3349aba986ec86bada083103491b1597eb7bbfb5.tar.gz
Use regular setup.py script
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py34
1 files changed, 34 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..866eb89
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,34 @@
+from distutils.core import setup
+
+from pexpect import __version__
+
+setup (name='pexpect',
+ version=__version__,
+ py_modules=['pexpect', 'pxssh', 'fdpexpect', 'FSM', 'screen', 'ANSI'],
+ description='Pexpect is a pure Python Expect. It allows easy control of other applications.',
+ author='Noah Spurrier',
+ author_email='noah@noah.org',
+ url='http://pexpect.sourceforge.net/',
+ license='MIT license',
+ platforms='UNIX',
+ classifiers = [
+ 'Development Status :: 4 - Beta',
+ 'Environment :: Console',
+ 'Environment :: Console (Text Based)',
+ 'Intended Audience :: Developers',
+ 'Intended Audience :: System Administrators',
+ 'Intended Audience :: Quality Engineers',
+ 'License :: OSI Approved :: Python Software Foundation License',
+ 'Operating System :: POSIX',
+ 'Operating System :: MacOS :: MacOS X',
+ 'Programming Language :: Python',
+ 'Topic :: Software Development',
+ 'Topic :: Software Development :: Libraries :: Python Modules',
+ 'Topic :: Software Development :: Quality Assurance',
+ 'Topic :: Software Development :: Testing',
+ 'Topic :: System, System :: Archiving :: Packaging, System :: Installation/Setup',
+ 'Topic :: System :: Shells',
+ 'Topic :: System :: Software Distribution',
+ 'Topic :: Terminals, Utilities',
+ ],
+)