summaryrefslogtreecommitdiff
path: root/Zend/configure.in
diff options
context:
space:
mode:
authorZeev Suraski <zeev@php.net>1999-07-17 13:24:53 +0000
committerZeev Suraski <zeev@php.net>1999-07-17 13:24:53 +0000
commit101e1f4c0f1538018e89d3eb327dd734e2963e46 (patch)
tree8f922e0798303ed9ea77cb91ab2133fa7c7d367a /Zend/configure.in
parentdd148848773b2ce8b2fe5427ea94085f6beb8df7 (diff)
downloadphp-git-101e1f4c0f1538018e89d3eb327dd734e2963e46.tar.gz
Debug on by default
Diffstat (limited to 'Zend/configure.in')
-rw-r--r--Zend/configure.in8
1 files changed, 4 insertions, 4 deletions
diff --git a/Zend/configure.in b/Zend/configure.in
index b0217eb04c..dc3739e7b9 100644
--- a/Zend/configure.in
+++ b/Zend/configure.in
@@ -92,7 +92,7 @@ AC_REPLACE_FUNCS(getopt)
AC_MSG_CHECKING(whether to include debugging symbols)
AC_ARG_ENABLE(debug,
-[ --enable-debug Compile with debugging symbols],
+[ --disable-debug Compile without debugging symbols],
[
if test "$enableval" = "yes"; then
AC_MSG_RESULT(yes)
@@ -107,9 +107,9 @@ AC_ARG_ENABLE(debug,
DEBUG_CFLAGS=""
fi
],[
- AC_MSG_RESULT(no)
- AC_DEFINE(ZEND_DEBUG,0)
- DEBUG_CFLAGS=""
+ AC_MSG_RESULT(yes)
+ AC_DEFINE(ZEND_DEBUG,1)
+ DEBUG_CFLAGS="-g"
])
AC_SUBST(DEBUG_CFLAGS)
CFLAGS="$CFLAGS $DEBUG_CFLAGS"