summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSammy Kaye Powers <sammyk@php.net>2020-07-16 16:31:10 -0700
committerSammy Kaye Powers <sammyk@php.net>2020-09-18 14:26:44 -0700
commit12306728c5f37dc371bc39f5fe2bf8e928368235 (patch)
treeeed1bf4671bc1c46e6a8e7a30b07bd4e9a7bc1d2 /configure.ac
parent30bb15b24a266eae1577b68cd980241b1a5adf40 (diff)
downloadphp-git-12306728c5f37dc371bc39f5fe2bf8e928368235.tar.gz
Add system ID entropy API
The `zend_system_id` is a (true global) system ID that fingerprints a process state. When extensions add engine hooks during MINIT/startup, entropy is added the system ID for each hook. This allows extensions to identify that changes have been made to the engine since the last PHP process restart. Closes GH-5871
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f82783a03b..a6ff4e707a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1464,7 +1464,7 @@ PHP_ADD_SOURCES(Zend, \
zend_closures.c zend_weakrefs.c zend_float.c zend_string.c zend_signal.c zend_generators.c \
zend_virtual_cwd.c zend_ast.c zend_objects.c zend_object_handlers.c zend_objects_API.c \
zend_default_classes.c zend_inheritance.c zend_smart_str.c zend_cpuinfo.c zend_gdb.c \
- zend_observer.c, \
+ zend_observer.c zend_system_id.c, \
-DZEND_ENABLE_STATIC_TSRMLS_CACHE=1)
PHP_ADD_BUILD_DIR(main main/streams)