summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Kokot <peterkokot@gmail.com>2019-03-17 16:22:02 +0100
committerPeter Kokot <peterkokot@gmail.com>2019-03-30 02:01:02 +0100
commit3207741df0ac71dc78f8b8c54c4b3a44553208f0 (patch)
treef3db7084e52e84e350ede97d97a1663c9b89baf5 /configure.ac
parent072eb6dd77b079a6f90ca5b155f9b0add1b5f2d4 (diff)
downloadphp-git-3207741df0ac71dc78f8b8c54c4b3a44553208f0.tar.gz
Refactor PHP_PROG_BISON and PHP_PROG_RE2C
This patch refactors these macros to also checks for the required given versions of bison and re2c. - PHP_PROG_RE2C and PHP_PROG_BISON take optional args - minmimum version required, and bison also excluded versions. - Instead of caching values this uses manual checking and messaging outputs. - It looks like the minimum version of RE2C 0.13.4 is working ok so far. The genfiles script improvements: - Add make override in genfiles - Move checkings from makedist to genfiles - Refactored output messages - Various minor enhancements
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 2 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index 2205c11bd8..e79be39572 100644
--- a/configure.ac
+++ b/configure.ac
@@ -194,17 +194,8 @@ PHP_RUNPATH_SWITCH
dnl Checks for some support/generator progs
PHP_PROG_AWK
-PHP_PROG_BISON
-PHP_PROG_RE2C
-
-dnl Check if bison generated files exist when bison does not..
-case $php_cv_bison_version in
- ""|invalid[)]
- if ! test -f "$abs_srcdir/Zend/zend_language_parser.h" || ! test -f "$abs_srcdir/Zend/zend_language_parser.c" ; then
- AC_MSG_ERROR([bison is required to build PHP/Zend when building a GIT checkout!])
- fi
- ;;
-esac
+PHP_PROG_BISON([3.0.0])
+PHP_PROG_RE2C([0.13.4])
PHP_ARG_ENABLE([re2c-cgoto],
[whether to enable computed goto gcc extension with re2c],