summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Carlier <devnexen@gmail.com>2020-08-16 17:30:24 +0000
committerNikita Popov <nikita.ppv@gmail.com>2020-08-24 11:37:48 +0200
commit32c6a0bbbbeddc93d14273326ecd3604961d3f0d (patch)
tree6b572670036ea4995b5cd15be79dc1fa43428f1f /configure.ac
parentc925028d49febfe2fbec2de148e5fc24fa159bd1 (diff)
downloadphp-git-32c6a0bbbbeddc93d14273326ecd3604961d3f0d.tar.gz
further network libraries detection for Haiku system.
Closes GH-5997.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 7 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 45614f8581..116bb6031f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -342,13 +342,13 @@ dnl Some systems (OpenServer 5) dislike -lsocket -lnsl, so we try to avoid -lnsl
dnl checks, if we already have the functions which are usually in libnsl. Also,
dnl uClibc will bark at linking with glibc's libnsl.
-PHP_CHECK_FUNC(socket, socket)
-PHP_CHECK_FUNC(socketpair, socket)
-PHP_CHECK_FUNC(htonl, socket)
-PHP_CHECK_FUNC(gethostname, nsl)
-PHP_CHECK_FUNC(gethostbyaddr, nsl)
-PHP_CHECK_FUNC(dlopen, dl)
-PHP_CHECK_FUNC(dlsym, dl)
+PHP_CHECK_FUNC(socket, socket, network)
+PHP_CHECK_FUNC(socketpair, socket, network)
+PHP_CHECK_FUNC(htonl, socket, network)
+PHP_CHECK_FUNC(gethostname, nsl, network)
+PHP_CHECK_FUNC(gethostbyaddr, nsl, network)
+PHP_CHECK_FUNC(dlopen, dl, root)
+PHP_CHECK_FUNC(dlsym, dl, root)
if test "$ac_cv_func_dlopen" = "yes"; then
AC_DEFINE(HAVE_LIBDL, 1, [ ])
fi