summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNikita Popov <nikita.ppv@gmail.com>2020-05-14 09:39:03 +0200
committerNikita Popov <nikita.ppv@gmail.com>2020-05-14 09:39:03 +0200
commitae5ca5459f9b724495c967eaa72b414c4ccb8c8b (patch)
tree55d154c404ae7794d25e5c240bc3c1b3ce863bae /configure.ac
parenta4cc9d83a130cd99c5074ce3a38e519757c15384 (diff)
parentae1d4a820a5c95acbffba903cf1e61261308078e (diff)
downloadphp-git-ae5ca5459f9b724495c967eaa72b414c4ccb8c8b.tar.gz
Merge branch 'PHP-7.4'
* PHP-7.4: Fix lcov genhtml: ERROR: cannot read [file] Properly detect CRC32 APIs on aarch64 from configure
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1a17aa904d..5f38fd580e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -668,6 +668,12 @@ if test "x$php_crypt_r" = "x1"; then
PHP_CRYPT_R_STYLE
fi
+AC_CACHE_CHECK([for aarch64 CRC32 API], ac_cv_func___crc32d,
+[AC_LINK_IFELSE([AC_LANG_PROGRAM([[#include <arm_acle.h>]],[[__crc32d(0, 0);]])],[ac_cv_func___crc32d=yes],[ac_cv_func___crc32d="no"])])
+if test "$ac_cv_func___crc32d" = "yes"; then
+ AC_DEFINE([HAVE_AARCH64_CRC32], [1], [Define when aarch64 CRC32 API is available.])
+fi
+
dnl Check for asm goto support.
AC_CACHE_CHECK([for asm goto], ac_cv__asm_goto,
[AC_RUN_IFELSE([AC_LANG_SOURCE([[