summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorFlorian Weimer <fweimer@redhat.com>2019-09-09 21:29:03 +0200
committerChristoph M. Becker <cmbecker69@gmx.de>2019-09-10 12:32:14 +0200
commitaeaab8ee3e52f74c042a861e394437d6554b36be (patch)
tree6e34d83e2cc360b01e804bf2e0e15597059085bc /configure.ac
parent0128f6eb8466cacfac5141382490bc385c9db8c0 (diff)
downloadphp-git-aeaab8ee3e52f74c042a861e394437d6554b36be.tar.gz
Port various autoconf bits to C99 compilers
C99 no longer has implicit function declarations and implicit ints. Current GCC versions enable them as an extension, but this will change in a future GCC version.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d759b02751..e15b83ca25 100644
--- a/configure.ac
+++ b/configure.ac
@@ -662,6 +662,8 @@ AC_CACHE_CHECK([for getaddrinfo], ac_cv_func_getaddrinfo,
[[struct addrinfo *g,h;g=&h;getaddrinfo("","",g,&g);]])],[AC_RUN_IFELSE([AC_LANG_SOURCE([[
#include <netdb.h>
#include <sys/types.h>
+#include <string.h>
+#include <stdlib.h>
#ifndef AF_INET
# include <sys/socket.h>
#endif