summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJani Taskinen <jani@php.net>2010-11-13 22:22:51 +0000
committerJani Taskinen <jani@php.net>2010-11-13 22:22:51 +0000
commit200dcee22d9790944dbb4f83efef51963a3b35bb (patch)
tree0a4f773e22b02be8b14bca2e7e2c4d15a645d2f1 /configure.in
parentc95e919e3e815b77adea9e565a84f2d38c5b0242 (diff)
downloadphp-git-200dcee22d9790944dbb4f83efef51963a3b35bb.tar.gz
- Simplified the DTrace configure macros, one is enough
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 3 insertions, 11 deletions
diff --git a/configure.in b/configure.in
index 5ebd1dfb64..60a5ad49a0 100644
--- a/configure.in
+++ b/configure.in
@@ -881,22 +881,21 @@ fi
dnl ##
dnl ## DTRACE CHECKS
-dnl ## this needs to be done before SAPI configuration
+dnl ## Note: this has to be done after SAPI configuration!
dnl ##
PHP_ARG_ENABLE(dtrace, whether to enable DTrace support,
[ --enable-dtrace Enable DTrace support], no, no)
if test "$PHP_DTRACE" = "yes"; then
AC_CHECK_HEADERS([sys/sdt.h], [
- PHP_ADD_DTRACE([Zend/zend_dtrace.d], [main/main.c, Zend/zend_API.c \
+ PHP_INIT_DTRACE([Zend/zend_dtrace.d],[Zend/zend_dtrace_gen.h],[main/main.c Zend/zend_API.c \
Zend/zend_execute.c Zend/zend_exceptions.c \
Zend/zend_dtrace.c Zend/zend.c])
AC_DEFINE(HAVE_DTRACE, 1, [Whether to enable DTrace support])
- PHP_INIT_DTRACE([Zend/zend_dtrace.d], [Zend/zend_dtrace_gen.h])
+ PHP_SUBST(PHP_DTRACE_OBJS)
], [
AC_MSG_ERROR([Cannot find sys/sdt.h which is required for DTrace support])
])
- PHP_SUBST(PHP_DTRACE_OBJS)
fi
AC_MSG_CHECKING([how big to make fd sets])
@@ -1447,13 +1446,6 @@ PHP_ADD_MAKEFILE_FRAGMENT($abs_srcdir/scripts/Makefile.frag,$abs_srcdir/scripts,
PHP_ADD_MAKEFILE_FRAGMENT($abs_srcdir/Makefile.frag,$abs_srcdir/Zend,Zend)
PHP_ADD_MAKEFILE_FRAGMENT($abs_srcdir/Zend/Makefile.frag,$abs_srcdir/Zend,Zend)
-if test "$PHP_DTRACE" = "yes"; then
- case $host_alias in
- *solaris*)
- PHP_GENERATE_DTRACE([Zend/zend_dtrace.d],$php_build_target);;
- esac
-fi
-
PHP_GEN_BUILD_DIRS
PHP_GEN_GLOBAL_MAKEFILE