summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorfoobar <sniper@php.net>2005-11-30 15:01:34 +0000
committerfoobar <sniper@php.net>2005-11-30 15:01:34 +0000
commit5b6cc7d96cb2df5ff8825fe622eb6f38fd663e76 (patch)
treec5e59afb4bb0751edac5ac17fcf6449adced982d /configure.in
parente20b4ab640c6072533b669f42b180c52cbdc7f78 (diff)
downloadphp-git-5b6cc7d96cb2df5ff8825fe622eb6f38fd663e76.tar.gz
MFH: - Fix the ccache detection
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 7 insertions, 8 deletions
diff --git a/configure.in b/configure.in
index 582bc9a235..1f7d7ef2d8 100644
--- a/configure.in
+++ b/configure.in
@@ -608,14 +608,13 @@ if test "$PHP_GCOV" = "yes"; then
fi
dnl Check if ccache is being used
- dnl FIXME: Need a check for ccache usage, the one below does not work!
- PHP_CHECK_GCC_ARG([--ccache-skip], [gcc_ccache=yes])
-
- if test "$gcc_ccache" = "yes"; then
- if test -z "$CCACHE_DISABLE" || test "$CCACHE_DISABLE" != "1"; then
- AC_MSG_ERROR([ccache must be disabled when --enable-gcov option is used. You can disable ccache by setting environment variable CCACHE_DISABLE=1.])
- fi
- lcov_target="lcov-ccache"
+ case `$php_shtool path $CC` in
+ *ccache*[)] gcc_ccache=yes;;
+ *[)] gcc_ccache=no;;
+ esac
+
+ if test "$gcc_ccache" = "yes" && (test -z "$CCACHE_DISABLE" || test "$CCACHE_DISABLE" != "1"); then
+ AC_MSG_ERROR([ccache must be disabled when --enable-gcov option is used. You can disable ccache by setting environment variable CCACHE_DISABLE=1.])
fi
ltp_version_list="1.4"