summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorSascha Schumann <sas@php.net>2001-08-21 11:45:33 +0000
committerSascha Schumann <sas@php.net>2001-08-21 11:45:33 +0000
commit95347cd868b2524ea1812ec36cee7479a745af4b (patch)
tree4be3c053228bedd1bf925a5c6b0860d46886b9a2 /configure.in
parent9350a23b8f58b898ca90434d8ab00f013230dcd4 (diff)
downloadphp-git-95347cd868b2524ea1812ec36cee7479a745af4b.tar.gz
Further work on autoconf-2.5x support
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 6 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 90b0578855..aee8243cd8 100644
--- a/configure.in
+++ b/configure.in
@@ -122,6 +122,7 @@ AC_PROG_LN_S
AC_PROG_LEX
if test -n "$LEX"; then
AC_DECL_YYTEXT
+ :
fi
dnl ## Make flex scanners use const if they can, even if __STDC__ is not
@@ -934,7 +935,7 @@ pear/scripts/pearize pear/scripts/phptar TSRM/Makefile $PHP_OUTPUT_FILES"
AC_OUTPUT($ALL_OUTPUT_FILES, [], [
-if test "\$CONFIG_FILES" = "$ALL_OUTPUT_FILES"; then
+if test "\$CONFIG_FILES" = "$ALL_OUTPUT_FILES" || test -z "\$CONFIG_FILES"; then
REDO_ALL=yes
fi
@@ -953,9 +954,10 @@ fi
# Create configuration headers
#
-if test -d TSRM; then
- echo '#include "../main/php_config.h"' > TSRM/tsrm_config.h
-fi
+test -d TSRM || mkdir TSRM
+echo '#include "../main/php_config.h"' > TSRM/tsrm_config.h
+
+test -d Zend || mkdir Zend
cat >Zend/zend_config.h <<FEO
#include "../main/php_config.h"