summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRasmus Lerdorf <rasmus@php.net>2002-10-04 04:47:35 +0000
committerRasmus Lerdorf <rasmus@php.net>2002-10-04 04:47:35 +0000
commit989a61ed98f1865ac926d114448f0ebfa3a8ec43 (patch)
treec444efa3d6efd8a0f367b5251ff0092ef7da95bf /configure.in
parent114dff39cefe7cdfddf6b4381da5c1c6f07e507f (diff)
downloadphp-git-989a61ed98f1865ac926d114448f0ebfa3a8ec43.tar.gz
As discussed, add --with-config-file-scan-dir compile-time switch defining
a directory which will be scanned for *.ini files after the main php.ini file has been parsed. This makes it much easier to automatically deploy a modular PHP since adding extensions which have their own ini switches can now be done by simply dropping a foo.ini file in the right directory and restarting. A list of parsed ini files is maintained and shown on the phpinfo page.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 54b3934402..e5f0830d9b 100644
--- a/configure.in
+++ b/configure.in
@@ -570,6 +570,12 @@ if test "$PHP_CONFIG_FILE_PATH" = "DEFAULT"; then
esac
fi
+PHP_ARG_WITH(config-file-scan-dir,[directory to be scanned for configuration files],
+[ --with-config-file-scan-dir=PATH ], DEFAULT, no)
+if test "$PHP_CONFIG_FILE_SCAN_DIR" = "DEFAULT"; then
+ PHP_CONFIG_FILE_SCAN_DIR=""
+fi
+
# compatibility
if test -z "$with_pear" && test "$enable_pear" = "no"; then
with_pear=no
@@ -890,6 +896,7 @@ EXPANDED_LIBDIR=$libdir
EXPANDED_SYSCONFDIR=`eval echo $sysconfdir`
EXPANDED_DATADIR=$datadir
EXPANDED_PHP_CONFIG_FILE_PATH=`eval echo "$PHP_CONFIG_FILE_PATH"`
+EXPANDED_PHP_CONFIG_FILE_SCAN_DIR=`eval echo "$PHP_CONFIG_FILE_SCAN_DIR"`
INCLUDE_PATH=.:$EXPANDED_PEAR_INSTALLDIR
exec_prefix=$old_exec_prefix
@@ -905,6 +912,7 @@ AC_SUBST(EXPANDED_DATADIR)
AC_SUBST(EXPANDED_SYSCONFDIR)
AC_SUBST(EXPANDED_LOCALSTATEDIR)
AC_SUBST(EXPANDED_PHP_CONFIG_FILE_PATH)
+AC_SUBST(EXPANDED_PHP_CONFIG_FILE_SCAN_DIR)
PHP_UTILIZE_RPATHS