summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorGwynne Raskind <gwynne@php.net>2009-11-30 21:38:44 +0000
committerGwynne Raskind <gwynne@php.net>2009-11-30 21:38:44 +0000
commitb2cc8c69dc55924b5de3d38eaeddb26e3de4d7db (patch)
tree8b2e213eb18fe032c9487bf6edfd410be0ee29d5 /configure.in
parent50a24392e95cf316a35dfbbde4e4d1d2078397cb (diff)
downloadphp-git-b2cc8c69dc55924b5de3d38eaeddb26e3de4d7db.tar.gz
The old Darwin hack is BROKEN and INCORRECT. It works only for Darwin 9, not 10, and uses an ugly CFLAGS hack that messes with the entire build. This version sets one cached value to the correct result for Darwin 9 and 10. It's cleaner, has no side effects, has nothing to do with Autoconf versions, and works for everyone.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in32
1 files changed, 8 insertions, 24 deletions
diff --git a/configure.in b/configure.in
index 4d729fcc54..788a3f0f9d 100644
--- a/configure.in
+++ b/configure.in
@@ -122,21 +122,6 @@ dnl or the contents of libs.
$php_shtool mkdir -p libs
rm -f libs/*
-dnl Darwin 9 hack
-dnl Because the default debugging format used by Apple's GCC on Mac OS 10.5
-dnl causes errors in all current and past versions of Autoconf, we do a little
-dnl messing with the CFLAGS here to trick it.
-php_did_darwin9_cheat=0
-case $host_alias in
-*darwin9*)
- hasg=`echo $CFLAGS | grep -E '(^-g)|([[:space:]]-g)'`
- if test x"$hasg" = "x"; then
- php_did_darwin9_cheat=1
- CFLAGS="$CFLAGS -gstabs"
- fi
- ;;
-esac
-
dnl Checks for programs.
dnl -------------------------------------------------------------------------
@@ -1339,6 +1324,14 @@ PHP_CONFIGURE_PART(Configuring libtool)
LDFLAGS="$LDFLAGS $PHP_AIX_LDFLAGS"
+dnl Autoconf 2.13's libtool checks go slightly nuts on Mac OS X 10.5 and 10.6.
+dnl This hack works around it. Ugly.
+case $host_alias in
+*darwin9*|*darwin10*)
+ ac_cv_exeext=
+ ;;
+esac
+
dnl Only allow AC_PROG_CXX and AC_PROG_CXXCPP if they are explicitly called (by PHP_REQUIRE_CXX).
dnl Otherwise AC_PROG_LIBTOOL fails if there is no working C++ compiler.
AC_PROVIDE_IFELSE([PHP_REQUIRE_CXX], [], [
@@ -1362,15 +1355,6 @@ SHARED_LIBTOOL='$(LIBTOOL)'
CC=$old_CC
-dnl Finish the Darwin hack
-if test "$php_did_darwin9_cheat" -eq 1; then
- if test "$PHP_DEBUG" = "1"; then
- CFLAGS=`echo "$CFLAGS" | $SED -e 's/-gstabs/-g/g'`
- else
- CFLAGS=`echo "-O2 $CFLAGS" | $SED -e 's/-gstabs//g'`
- fi
-fi
-
PHP_CONFIGURE_PART(Generating files)
CXXFLAGS_CLEAN=$CXXFLAGS