summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDmitry Stogov <dmitry@zend.com>2015-04-16 14:45:08 +0300
committerDmitry Stogov <dmitry@zend.com>2015-04-16 14:45:08 +0300
commite38ed4c28ffe56f910626870667b374ac5ad1481 (patch)
treec6681c4d7f855cb94515930b1c45aee1a1ae4251 /configure.in
parent05232cc810b39ff6f5a0307119bd76a548fe34be (diff)
downloadphp-git-e38ed4c28ffe56f910626870667b374ac5ad1481.tar.gz
Changed zend_smart_str allocation granularity to do the better job together with Zend MM and avoid useless calls to erealloc().
The actual reallocation routiones are seprated from inlined code to reduce code size.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 4575405403..ffc714ff5f 100644
--- a/configure.in
+++ b/configure.in
@@ -1494,7 +1494,7 @@ PHP_ADD_SOURCES(Zend, \
zend_iterators.c zend_interfaces.c zend_exceptions.c zend_strtod.c zend_gc.c \
zend_closures.c zend_float.c zend_string.c zend_signal.c zend_generators.c \
zend_virtual_cwd.c zend_ast.c zend_objects.c zend_object_handlers.c zend_objects_API.c \
- zend_default_classes.c zend_inheritance.c, \
+ zend_default_classes.c zend_inheritance.c zend_smart_str.c, \
-DZEND_ENABLE_STATIC_TSRMLS_CACHE=1)
dnl Selectively disable optimization due to high RAM usage during