summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorSascha Schumann <sas@php.net>2002-09-29 16:22:49 +0000
committerSascha Schumann <sas@php.net>2002-09-29 16:22:49 +0000
commite6e54605b7c4153be53a4ee62429fcc4eb2d8970 (patch)
treed805a9b1167884923e1754fd8e5557cdf4fc77fc /configure.in
parent2af630f87db2e08a0837d062bcad2cd403bed4e7 (diff)
downloadphp-git-e6e54605b7c4153be53a4ee62429fcc4eb2d8970.tar.gz
Follow Yasuo's suggestion and build sapi program's under the sapi-specific
directory. Move sapi-specific makefile fragments to their respective directory. Create an embed sapi module which resides in its own dir now.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 1 insertions, 8 deletions
diff --git a/configure.in b/configure.in
index 4bc97e4d1a..4f7fc56398 100644
--- a/configure.in
+++ b/configure.in
@@ -215,7 +215,6 @@ dnl SAPI configuration.
dnl -------------------------------------------------------------------------
dnl paths to the targets are relative to the build directory
-SAPI_PROGRAM=php
SAPI_SHARED=libs/libphp4.$SHLIB_SUFFIX_NAME
SAPI_STATIC=libs/libphp4.a
SAPI_LIBTOOL=libphp4.la
@@ -225,7 +224,7 @@ PHP_CONFIGURE_PART(Configuring SAPI modules)
esyscmd(./scripts/config-stubs sapi)
if test "$PHP_SAPI" = "default"; then
- PHP_SELECT_SAPI(cgi, program, cgi_main.c getopt.c)
+ PHP_SELECT_SAPI(cgi, program, cgi_main.c getopt.c,,'$(SAPI_CGI_PATH)')
fi
AC_MSG_CHECKING([for chosen SAPI module])
@@ -1078,12 +1077,6 @@ fi
PHP_ADD_SOURCES_X(Zend, zend_execute.c,,PHP_GLOBAL_OBJS,,$flag)
-
-PHP_ADD_SOURCES_X(main, php_embed.c,, PHP_LIB_OBJS)
-PHP_LIB_OBJS="$PHP_GLOBAL_OBJS $PHP_LIB_OBJS main/internal_functions_cli.lo"
-PHP_SUBST(PHP_LIB_OBJS)
-
-
PHP_ADD_BUILD_DIR(main)
PHP_ADD_BUILD_DIR(regex)
PHP_ADD_BUILD_DIR(sapi/$PHP_SAPI sapi/cli)