summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJohn Bailey <rekkanoryo@rekkanoryo.org>2010-03-20 21:04:17 +0000
committerJohn Bailey <rekkanoryo@rekkanoryo.org>2010-03-20 21:04:17 +0000
commit2328cb186ad61a72032bab133b865bf16bfef64f (patch)
tree65d71df0b9de029884f3f214d322ebc716dcaa1c /Makefile.am
parent8df1142ed2753e66d45d1a5445b58eb975c67cce (diff)
downloadpidgin-2328cb186ad61a72032bab133b865bf16bfef64f.tar.gz
Make --disable-nls work again. Fixes #11548.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 8 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index 7607407eaa..599f87029d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -71,22 +71,24 @@ packages:
gpg --verify pidgin-$(PACKAGE_VERSION).tar.gz.asc pidgin-$(PACKAGE_VERSION).tar.gz
gpg --verify pidgin-$(PACKAGE_VERSION).tar.bz2.asc pidgin-$(PACKAGE_VERSION).tar.bz2
+if INSTALL_I18N
+PO_DIR=po
+DESKTOP_FILE=pidgin.desktop
+
if ENABLE_GTK
appsdir = $(datadir)/applications
apps_in_files = pidgin.desktop.in
apps_DATA = $(apps_in_files:.desktop.in=.desktop)
@INTLTOOL_DESKTOP_RULE@
GTK_DIR=pidgin
-endif
+endif #ENABLE_GTK
+
+endif #INSTALL_I18N
if ENABLE_GNT
GNT_DIR=finch
endif
-if INSTALL_I18N
-PO_DIR=po
-endif
-
# This is phony, so that we always try to rebuild it. If it succeeds
# in calculating changes, it produces its target; otherwise, its
# target does not exist.
@@ -146,5 +148,5 @@ endif
distuninstallcheck_listfiles = \
find . -type f -print | grep -v perl | grep -v Purple.3pm
-DISTCLEANFILES= pidgin.desktop libpurple/gconf/purple.schemas intltool-extract \
+DISTCLEANFILES= $(DESKTOP_FILE) libpurple/gconf/purple.schemas intltool-extract \
intltool-merge intltool-update