summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAnkit Vani <a@nevitus.org>2014-01-31 17:15:51 +0530
committerAnkit Vani <a@nevitus.org>2014-01-31 17:15:51 +0530
commitbafa3d0d8dcb7c858c81088e5152a53d0f514fce (patch)
tree3a9c25e61e2073b43784e07f8aa3cb834c9519ee /Makefile.am
parentb46e767314538215764aa3e0f115fba4960921d5 (diff)
downloadpidgin-bafa3d0d8dcb7c858c81088e5152a53d0f514fce.tar.gz
Prepare files for gtk-doc conversion.
Add libraries for finch and pidgin.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am22
1 files changed, 3 insertions, 19 deletions
diff --git a/Makefile.am b/Makefile.am
index 05a1515658..e268063015 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,14 +2,12 @@ EXTRA_DIST = \
COPYRIGHT \
ChangeLog.API \
ChangeLog.win32 \
- Doxyfile.in \
HACKING \
Makefile.mingw \
PLUGIN_HOWTO \
README.hg \
README.mingw \
config.h.mingw \
- doxy2devhelp.xsl \
fix-casts.sh \
intltool-extract.in \
intltool-merge.in \
@@ -121,23 +119,9 @@ package_revision.h: package_revision_raw.txt
# line does is tell 'distcheck' to shut up and ignore those two files.
distcleancheck_listfiles = find . -type f -a ! -name package_revision.h
-SUBDIRS = . libpurple doc $(GNT_DIR) $(GTK_DIR) m4macros $(PO_DIR) share/ca-certs share/sounds
-
-docs: Doxyfile
-if HAVE_DOXYGEN
- @echo "Running doxygen..."
- @doxygen
-if HAVE_XSLTPROC
- @echo "Generating devhelp index..."
- @xsltproc $(top_srcdir)/doxy2devhelp.xsl doc/xml/index.xml > doc/html/pidgin.devhelp
- @echo "(Symlink $$(pwd)/doc/html to ~/.local/share/gtk-doc/html/pidgin to make devhelp see the documentation)"
-else
- @echo "Not generating devhelp index: xsltproc was not found by configure"
-endif
-else
- @echo "doxygen was not found during configure. Unable to build documentation."
- @echo;
-endif
+DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc
+
+SUBDIRS = . m4macros libpurple $(GNT_DIR) $(GTK_DIR) $(PO_DIR) share/ca-certs share/sounds doc
# perl's MakeMaker uninstall foo doesn't work well with DESTDIR set, which
# breaks "make distcheck" unless we ignore perl things