summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorWill Thompson <resiak@pidgin.im>2007-10-13 15:44:43 +0000
committerWill Thompson <resiak@pidgin.im>2007-10-13 15:44:43 +0000
commite1de7b9d415d6ff495957694ff23b7ac3f234d9a (patch)
treeb046028fede3100cb85f3069b19ff6e3a6b865d3 /Makefile.am
parentaa4ae0365d7784ed16a84c57a5e4f1d623295651 (diff)
downloadpidgin-e1de7b9d415d6ff495957694ff23b7ac3f234d9a.tar.gz
Add some xsl magic to generate a .devhelp index from doxygen's XML output,
allowing the documentation to be viewed in Devhelp. It's not perfect --- there are some broken links and the transformation is a bit fragile --- but works well enough to be useful.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 6f9910256f..dc7f214a16 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -48,6 +48,13 @@ docs: Doxyfile
if HAVE_DOXYGEN
@echo "Running doxygen..."
@doxygen
+if HAVE_XSLTPROC
+ @echo "Generating devhelp index..."
+ @xsltproc doxy2devhelp.xsl doc/xml/index.xml > doc/html/pidgin.devhelp
+ @echo "(Symlink doc/html to ~/.local/share/gtk-doc/html/pidgin to make devhelp see the documentation)"
+else
+ @echo "Not generating devhelp index: xsltproc was not found by configure"
+endif
else
@echo "doxygen was not found during configure. Aborting."
@echo;