summaryrefslogtreecommitdiff
path: root/finch/meson.build
diff options
context:
space:
mode:
authorElliott Sales de Andrade <quantum.analyst@gmail.com>2020-09-16 02:04:11 -0500
committerElliott Sales de Andrade <quantum.analyst@gmail.com>2020-09-16 02:04:11 -0500
commit1237f70653f4cb95b17e8104a2ade2966f7c45b2 (patch)
tree30ae2602822ba696032624a2b43ec4afd5ccef64 /finch/meson.build
parentea31b557a09b647019e4fa26c48289e33577ae20 (diff)
downloadpidgin-1237f70653f4cb95b17e8104a2ade2966f7c45b2.tar.gz
Switch join_paths and + to /.
Testing Done: Ran `ninja install`, though didn't actually check the results. Reviewed at https://reviews.imfreedom.org/r/121/
Diffstat (limited to 'finch/meson.build')
-rw-r--r--finch/meson.build7
1 files changed, 3 insertions, 4 deletions
diff --git a/finch/meson.build b/finch/meson.build
index dc77f2c1c1..8a44da7b6e 100644
--- a/finch/meson.build
+++ b/finch/meson.build
@@ -32,7 +32,7 @@ if get_option('consoleui')
ncurses = dependency('ncursesw', required : false)
if ncurses.found()
foreach location : ncursesw_header_paths
- f = location + 'ncurses.h'
+ f = location / 'ncurses.h'
if compiler.has_header_symbol(f, 'get_wch',
prefix : '#define _XOPEN_SOURCE_EXTENDED')
ncurses_header = f
@@ -44,7 +44,7 @@ if get_option('consoleui')
ncurses_libs = compiler.find_library('ncursesw', required : false)
if ncurses_libs.found()
foreach location : ncursesw_header_paths
- f = location + 'ncurses.h'
+ f = location / 'ncurses.h'
if compiler.has_header_symbol(f, 'get_wch',
prefix : '#define _XOPEN_SOURCE_EXTENDED')
ncurses_available = true
@@ -176,8 +176,7 @@ if enable_consoleui
output : 'finch.h',
configuration : finch_h_conf,
install : true,
- install_dir : join_paths(get_option('includedir'),
- 'finch-3'))
+ install_dir : get_option('includedir') / 'finch-3')
install_headers(libfinch_headers, subdir : 'finch-3')