summaryrefslogtreecommitdiff
path: root/finch/meson.build
diff options
context:
space:
mode:
authorElliott Sales de Andrade <quantum.analyst@gmail.com>2021-10-18 01:51:02 -0500
committerElliott Sales de Andrade <quantum.analyst@gmail.com>2021-10-18 01:51:02 -0500
commit55fd0754377b9ef459e35da750eed571fdb2a081 (patch)
tree89ee674e3f89441087181a65d5e4da3b544aeebf /finch/meson.build
parent6b6709c256a2ded3769a8e717c9535e2a07ee646 (diff)
downloadpidgin-55fd0754377b9ef459e35da750eed571fdb2a081.tar.gz
Enable structured logging in Finch
And add log domains. Testing Done: Compile only. Reviewed at https://reviews.imfreedom.org/r/1062/
Diffstat (limited to 'finch/meson.build')
-rw-r--r--finch/meson.build16
1 files changed, 14 insertions, 2 deletions
diff --git a/finch/meson.build b/finch/meson.build
index 70da927fb0..2ed08c75f4 100644
--- a/finch/meson.build
+++ b/finch/meson.build
@@ -179,7 +179,14 @@ if enable_consoleui
libfinch_inc = include_directories('.')
libfinch = shared_library('finch3',
libfinch_SOURCES + libfinch_built_headers + libfinch_built_sources,
- c_args : ['-DSTANDALONE', '-DGNTSEAL_ENABLE', '-DFINCH_COMPILATION', ncurses_header],
+ c_args : [
+ '-DSTANDALONE',
+ '-DGNTSEAL_ENABLE',
+ '-DFINCH_COMPILATION',
+ ncurses_header,
+ '-DG_LOG_USE_STRUCTURED',
+ '-DG_LOG_DOMAIN="Finch"',
+ ],
include_directories : [toplevel_inc],
version : PURPLE_LIB_VERSION,
dependencies : [libpurple_dep, libgnt_dep, ncurses, glib, winmm],
@@ -220,7 +227,12 @@ if enable_consoleui
finch = executable('finch3',
finch_SOURCES,
- c_args : ['-DSTANDALONE', '-DGNTSEAL_ENABLE'],
+ c_args : [
+ '-DSTANDALONE',
+ '-DGNTSEAL_ENABLE',
+ '-DG_LOG_USE_STRUCTURED',
+ '-DG_LOG_DOMAIN="Finch"',
+ ],
dependencies : [libpurple_dep, libgnt_dep, libfinch_dep],
install : true)