summaryrefslogtreecommitdiff
path: root/finch/meson.build
diff options
context:
space:
mode:
authorGary Kramlich <grim@reaperworld.com>2021-09-24 02:56:53 -0500
committerGary Kramlich <grim@reaperworld.com>2021-09-24 02:56:53 -0500
commit7dba4638acac2e93aa9d12ab00cd7e4bbac331d8 (patch)
tree9e3570628bd588a81115ab9816f6f36548c2517d /finch/meson.build
parent967a370384f1e9b96551c26f3e906a043084e7f4 (diff)
downloadpidgin-7dba4638acac2e93aa9d12ab00cd7e4bbac331d8.tar.gz
Convert the gplugin subproject to use the auto fallback stuff of dependency.
Testing Done: Verified the the purples gir's loaded and were able to call into gplugin under python, when built as a subproject and against a system installed version. Reviewed at https://reviews.imfreedom.org/r/937/
Diffstat (limited to 'finch/meson.build')
-rw-r--r--finch/meson.build5
1 files changed, 1 insertions, 4 deletions
diff --git a/finch/meson.build b/finch/meson.build
index 8e18a6bf7e..0877682042 100644
--- a/finch/meson.build
+++ b/finch/meson.build
@@ -234,7 +234,7 @@ if enable_consoleui
Finch_gir_includes = [
libgnt_gir[0],
- gplugin_gir,
+ 'GPlugin-1.0',
# subproject needs to be before libpurple in the repo so that
# meson will use our variables and not try to discover them from
# libpurple.
@@ -250,9 +250,6 @@ if enable_consoleui
export_packages : 'finch',
nsversion : '@0@.@1@'.format(purple_major_version,
purple_minor_version),
- include_directories : [
- gplugin_include_directories,
- ],
install : true,
extra_args : ['-DFINCH_COMPILATION', '--quiet'])
endif