summaryrefslogtreecommitdiff
path: root/libpurple/meson.build
diff options
context:
space:
mode:
authorGary Kramlich <grim@reaperworld.com>2022-08-11 03:06:20 -0500
committerGary Kramlich <grim@reaperworld.com>2022-08-11 03:06:20 -0500
commit49bff88e408a010d681fcc97102fda00162257e1 (patch)
tree63d263800144918552dcd65625bb4655a2091db2 /libpurple/meson.build
parentd7d841d5b3170c8ee23cf2e3a6c45e1555b028d9 (diff)
downloadpidgin-49bff88e408a010d681fcc97102fda00162257e1.tar.gz
Remove some no longer necessary meson options
nettle was only used for the internal keyring which we dropped awhile ago. The nls and pixmaps options were originally created to decrease the iteration time for developers, but with meson dev environments this is no longer necessary as we don't need to install at all to test things. Testing Done: Ran `meson --wipe` with no issue and compiled. Reviewed at https://reviews.imfreedom.org/r/1577/
Diffstat (limited to 'libpurple/meson.build')
-rw-r--r--libpurple/meson.build33
1 files changed, 12 insertions, 21 deletions
diff --git a/libpurple/meson.build b/libpurple/meson.build
index c697121107..b277e0c922 100644
--- a/libpurple/meson.build
+++ b/libpurple/meson.build
@@ -363,27 +363,18 @@ libpurple_dep = declare_dependency(
meson.override_dependency(purple_filebase, libpurple_dep)
PURPLE3_URL_HANDLER_DESKTOP = 'purple3-url-handler.desktop'
-if get_option('nls')
- i18n = import('i18n')
- desktop_file_in = configure_file(
- input : 'data' / (PURPLE3_URL_HANDLER_DESKTOP + '.in.in'),
- output : PURPLE3_URL_HANDLER_DESKTOP + '.in',
- configuration : conf)
- i18n.merge_file(
- input : desktop_file_in,
- output : PURPLE3_URL_HANDLER_DESKTOP,
- po_dir : meson.project_source_root() / 'po',
- type : 'desktop',
- install : true,
- install_dir : get_option('datadir') / 'applications')
-else
- configure_file(
- input : 'data' / (PURPLE3_URL_HANDLER_DESKTOP + '.in.in'),
- output : PURPLE3_URL_HANDLER_DESKTOP,
- configuration : conf,
- install : true,
- install_dir : get_option('datadir') / 'applications')
-endif
+i18n = import('i18n')
+desktop_file_in = configure_file(
+ input : 'data' / (PURPLE3_URL_HANDLER_DESKTOP + '.in.in'),
+ output : PURPLE3_URL_HANDLER_DESKTOP + '.in',
+ configuration : conf)
+i18n.merge_file(
+ input : desktop_file_in,
+ output : PURPLE3_URL_HANDLER_DESKTOP,
+ po_dir : meson.project_source_root() / 'po',
+ type : 'desktop',
+ install : true,
+ install_dir : get_option('datadir') / 'applications')
subdir('tests')
subdir('example')