summaryrefslogtreecommitdiff
path: root/libpurple/meson.build
diff options
context:
space:
mode:
authorElliott Sales de Andrade <quantum.analyst@gmail.com>2023-03-10 01:42:06 -0600
committerElliott Sales de Andrade <quantum.analyst@gmail.com>2023-03-10 01:42:06 -0600
commit62982acaa4258b26324a9e7ee395814c279be2cc (patch)
treefc20db7731a337811ee10617728456828d9514f2 /libpurple/meson.build
parent2b47dafad6610554a321ff826bad6d83dce27cf9 (diff)
downloadpidgin-62982acaa4258b26324a9e7ee395814c279be2cc.tar.gz
Make PurpleRequestFieldInt into a GObject
This also does an `hg cp`, though with all the renaming of the parameter names, maybe that wasn't as useful for tracking the diff. Note, I didn't bother re-indenting some of the blocks, because they'll all eventually be moved when everything is subclassed. Testing Done: Compiled and opened Request Fields from Demo protocol. Reviewed at https://reviews.imfreedom.org/r/2334/
Diffstat (limited to 'libpurple/meson.build')
-rw-r--r--libpurple/meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/libpurple/meson.build b/libpurple/meson.build
index 9b255c195c..824bcb64cc 100644
--- a/libpurple/meson.build
+++ b/libpurple/meson.build
@@ -99,6 +99,7 @@ purple_coresources = [
'request.c',
'request/purplerequestfieldaccount.c',
'request/purplerequestfieldbool.c',
+ 'request/purplerequestfieldint.c',
'request/purplerequestfieldstring.c',
'request-datasheet.c',
'roomlist.c',
@@ -225,6 +226,7 @@ purple_coreheaders = [
purple_request_headers = [
'request/purplerequestfieldaccount.h',
'request/purplerequestfieldbool.h',
+ 'request/purplerequestfieldint.h',
'request/purplerequestfieldstring.h',
]