summaryrefslogtreecommitdiff
path: root/libpurple/meson.build
diff options
context:
space:
mode:
authorGary Kramlich <grim@reaperworld.com>2022-10-31 04:02:09 -0500
committerGary Kramlich <grim@reaperworld.com>2022-10-31 04:02:09 -0500
commit901f4ebdfe8b3a3740a0757c169cef54551dc381 (patch)
tree21ce0f8042a22a90bd05fbf9efe2033fb862548d /libpurple/meson.build
parentdf3f2aad7a4089fe49014c33f079cbda4cc9fce5 (diff)
downloadpidgin-901f4ebdfe8b3a3740a0757c169cef54551dc381.tar.gz
Create PurpleUi that merges PurpleCoreUiOps and PurpleUiInfo
This created a lot more refactoring that I imagined, but it's mostly just moving stuff around. I skipped the unit tests for now because we already have a `test_ui.[ch]` in the tests directory which we can/should move to a separate library or something, so it's available outside of the `libpurple/tests/` directory. Testing Done: Ran the unit tests, launched pidgin3, and launched finch3 with out issue. Bugs closed: PIDGIN-17697 Reviewed at https://reviews.imfreedom.org/r/1925/
Diffstat (limited to 'libpurple/meson.build')
-rw-r--r--libpurple/meson.build6
1 files changed, 2 insertions, 4 deletions
diff --git a/libpurple/meson.build b/libpurple/meson.build
index 592b09cb41..9c2df2169b 100644
--- a/libpurple/meson.build
+++ b/libpurple/meson.build
@@ -50,7 +50,6 @@ purple_coresources = [
'purpleconversation.c',
'purpleconversationmanager.c',
'purpleconversationuiops.c',
- 'purplecoreuiops.c',
'purplecredentialmanager.c',
'purplecredentialprovider.c',
'purpledebugui.c',
@@ -88,7 +87,7 @@ purple_coresources = [
'purplesqlite3.c',
'purplesqlitehistoryadapter.c',
'purpletags.c',
- 'purpleuiinfo.c',
+ 'purpleui.c',
'purplewhiteboard.c',
'purplewhiteboardmanager.c',
'purplewhiteboarduiops.c',
@@ -155,7 +154,6 @@ purple_coreheaders = [
'purpleconversation.h',
'purpleconversationmanager.h',
'purpleconversationuiops.h',
- 'purplecoreuiops.h',
'purplecredentialmanager.h',
'purplecredentialprovider.h',
'purpledebugui.h',
@@ -194,7 +192,7 @@ purple_coreheaders = [
'purplesqlite3.h',
'purplesqlitehistoryadapter.h',
'purpletags.h',
- 'purpleuiinfo.h',
+ 'purpleui.h',
'purplewhiteboard.h',
'purplewhiteboardmanager.h',
'purplewhiteboardops.h',