summaryrefslogtreecommitdiff
path: root/libpurple/meson.build
diff options
context:
space:
mode:
authorGary Kramlich <grim@reaperworld.com>2022-10-23 22:31:02 -0500
committerGary Kramlich <grim@reaperworld.com>2022-10-23 22:31:02 -0500
commitbcc3bac9e7f2fee4f0232c620963ab59edd9bb1a (patch)
tree7da9de4d29e7c467e6ff6196d87909401e9297ea /libpurple/meson.build
parenta70091a69ecd46f94b9ba484ff8fd351c4cae8fb (diff)
downloadpidgin-bcc3bac9e7f2fee4f0232c620963ab59edd9bb1a.tar.gz
Remove the upnp API
We already know that GUPnP isn't going to work for us and have started traversity to fill that gap. So in the meantime, we can just get rid of the existing UPnP API. Testing Done: Compiled Reviewed at https://reviews.imfreedom.org/r/1959/
Diffstat (limited to 'libpurple/meson.build')
-rw-r--r--libpurple/meson.build8
1 files changed, 3 insertions, 5 deletions
diff --git a/libpurple/meson.build b/libpurple/meson.build
index 99ffc8f88c..592b09cb41 100644
--- a/libpurple/meson.build
+++ b/libpurple/meson.build
@@ -101,7 +101,6 @@ purple_coresources = [
'signals.c',
'status.c',
'stun.c',
- 'upnp.c',
'util.c',
'version.c',
'xfer.c',
@@ -210,7 +209,6 @@ purple_coreheaders = [
'status.h',
'stun.h',
'tests.h',
- 'upnp.h',
'util.h',
'xfer.h',
'xmlnode.h',
@@ -323,9 +321,9 @@ libpurple = library('purple',
install : true,
version : PURPLE_LIB_VERSION,
dependencies : # static_link_libs
- [dnsapi, ws2_32, glib, gio, gplugin_dep, gupnp,
- gupnp_igd, libsoup, libxml, gdk_pixbuf, gstreamer,
- gstreamer_app, json, sqlite3, math])
+ [dnsapi, ws2_32, glib, gio, gplugin_dep, libsoup,
+ libxml, gdk_pixbuf, gstreamer, gstreamer_app, json,
+ sqlite3, math])
install_headers(purple_coreheaders,
subdir : purple_include_base)