summaryrefslogtreecommitdiff
path: root/libpurple/meson.build
diff options
context:
space:
mode:
authorElliott Sales de Andrade <quantum.analyst@gmail.com>2023-03-10 17:37:15 -0600
committerElliott Sales de Andrade <quantum.analyst@gmail.com>2023-03-10 17:37:15 -0600
commitce9173bdcf6fad2c97fc53527ceea6b475b1497a (patch)
treee5a4f9a762aba8ab8f45423f2e0431b472860044 /libpurple/meson.build
parent5c503c835674765e6bddb94ef34e931a02d930fe (diff)
downloadpidgin-ce9173bdcf6fad2c97fc53527ceea6b475b1497a.tar.gz
Make PurpleRequestFieldImage into a GObject
I'm not sure taking a `char*` and `gsize` is the best constructor; we can probably move this to `GdkPixbuf` or something now. Plus the properties would be nicer, and then it could change images on the fly. But that can happen later. Testing Done: Compiled and opened Request Fields from the Demo protocol Reviewed at https://reviews.imfreedom.org/r/2339/
Diffstat (limited to 'libpurple/meson.build')
-rw-r--r--libpurple/meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/libpurple/meson.build b/libpurple/meson.build
index d395cb1ca1..14b4614d7e 100644
--- a/libpurple/meson.build
+++ b/libpurple/meson.build
@@ -100,6 +100,7 @@ purple_coresources = [
'request/purplerequestfieldaccount.c',
'request/purplerequestfieldbool.c',
'request/purplerequestfieldchoice.c',
+ 'request/purplerequestfieldimage.c',
'request/purplerequestfieldint.c',
'request/purplerequestfieldlabel.c',
'request/purplerequestfieldlist.c',
@@ -230,6 +231,7 @@ purple_request_headers = [
'request/purplerequestfieldaccount.h',
'request/purplerequestfieldbool.h',
'request/purplerequestfieldchoice.h',
+ 'request/purplerequestfieldimage.h',
'request/purplerequestfieldint.h',
'request/purplerequestfieldlabel.h',
'request/purplerequestfieldlist.h',