summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorGary Kramlich <grim@reaperworld.com>2022-10-26 01:22:53 -0500
committerGary Kramlich <grim@reaperworld.com>2022-10-26 01:22:53 -0500
commit92cdbcdfd0e3065beccc7cc331996352de5999a7 (patch)
tree530226e28966cb47c3c914089fa36b8ba52dafd3 /meson.build
parent34cac601a4b22231e5a70f1152a2bcb434c99bf9 (diff)
downloadpidgin-92cdbcdfd0e3065beccc7cc331996352de5999a7.tar.gz
Remove the SILC protocol plugin
We've done a lot to try to keep this protocol plugin alive, but it crashes when you try to connect to silcnet and most distros don't even have the dependency anymore. Therefore, I declare it's time that we drop our support for it. Testing Done: Ran a full build and `ninja pidgin-pot` Reviewed at https://reviews.imfreedom.org/r/1970/
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build11
1 files changed, 1 insertions, 10 deletions
diff --git a/meson.build b/meson.build
index c9c2656833..53b4fbdc9b 100644
--- a/meson.build
+++ b/meson.build
@@ -340,12 +340,6 @@ else
enable_avahi = avahi_client.found() and avahi_glib.found()
endif
-
-#######################################################################
-# Check for SILC client includes and libraries
-#######################################################################
-silc = dependency('silcclient', version : '>= 1.1.1', required : get_option('silc'))
-
#######################################################################
# Check for Gadu-Gadu protocol library (libgadu)
#######################################################################
@@ -370,7 +364,7 @@ endif
DEFAULT_PRPLS = ['bonjour', 'demo', 'facebook', 'gg', 'irc', 'ircv3', 'jabber',
- 'novell', 'null', 'sametime', 'silc', 'zephyr']
+ 'novell', 'null', 'sametime', 'zephyr']
ALL_PRPLS = DEFAULT_PRPLS + ['null']
dynamic_list = get_option('dynamic-prpls').split(',')
@@ -385,8 +379,6 @@ foreach prpl : dynamic_list
# Do nothing.
elif prpl == 'bonjour' and not enable_avahi
# Do nothing.
- elif prpl == 'silc' and not silc.found()
- # Do nothing.
elif prpl == 'gg' and not libgadu.found()
# Do nothing.
elif prpl == 'zephyr' and IS_WIN32
@@ -406,7 +398,6 @@ DYNAMIC_JABBER = DYNAMIC_PRPLS.contains('jabber')
DYNAMIC_NOVELL = DYNAMIC_PRPLS.contains('novell')
DYNAMIC_NULL = DYNAMIC_PRPLS.contains('null')
DYNAMIC_SAMETIME = DYNAMIC_PRPLS.contains('sametime')
-DYNAMIC_SILC = DYNAMIC_PRPLS.contains('silc')
DYNAMIC_ZEPHYR = DYNAMIC_PRPLS.contains('zephyr')
conf.set('HAVE_SYS_UTSNAME_H',