summaryrefslogtreecommitdiff
path: root/doc/reference/finch/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'doc/reference/finch/meson.build')
-rw-r--r--doc/reference/finch/meson.build6
1 files changed, 5 insertions, 1 deletions
diff --git a/doc/reference/finch/meson.build b/doc/reference/finch/meson.build
index baa6a06d92..c7695855a8 100644
--- a/doc/reference/finch/meson.build
+++ b/doc/reference/finch/meson.build
@@ -10,7 +10,7 @@ if get_option('doc')
)
finch_doc = custom_target('finch-doc',
- input : [ finch_toml, libfinch_gir ],
+ input : [ finch_toml, libfinch_gir[0] ],
output : 'finch',
command : [
gidocgen,
@@ -21,8 +21,12 @@ if get_option('doc')
'--output-dir=@OUTPUT@',
'--no-namespace-dir',
'--content-dir=@0@'.format(meson.current_source_dir()),
+ '--add-include-path=@0@'.format(meson.global_build_root() / 'subprojects/gplugin/gplugin'),
+ '--add-include-path=@0@'.format(meson.global_build_root() / 'subprojects/libgnt'),
+ '--add-include-path=@0@'.format(meson.project_build_root() / 'libpurple'),
'@INPUT1@'
],
+ depends: [ libpurple_gir[0] ],
depend_files : [ finch_doc_content_files ],
build_by_default : true,
install : true,