summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorPradyun Gedam <3275593+pradyunsg@users.noreply.github.com>2021-02-23 13:37:25 +0000
committerGitHub <noreply@github.com>2021-02-23 13:37:25 +0000
commitbaaf66f70d84cf3367d5b43fec16762ca9703810 (patch)
tree3dd125fddb8beb3022450e57a910de6b5a03da80 /setup.py
parent270ddd3d034db844baaa30927331513b80fc4912 (diff)
parent20688ee8e8df1229312b0ed1a0b556ed7045c6b0 (diff)
downloadpip-baaf66f70d84cf3367d5b43fec16762ca9703810.tar.gz
Merge pull request #9591 from hexagonrecursion/open
Replace `open(file, 'r')` with `open(file)`
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index a413c5f67..26056f280 100644
--- a/setup.py
+++ b/setup.py
@@ -9,7 +9,7 @@ def read(rel_path):
here = os.path.abspath(os.path.dirname(__file__))
# intentionally *not* adding an encoding option to open, See:
# https://github.com/pypa/virtualenv/issues/201#issuecomment-3145690
- with open(os.path.join(here, rel_path), 'r') as fp:
+ with open(os.path.join(here, rel_path)) as fp:
return fp.read()