summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorPradyun Gedam <pradyunsg@gmail.com>2018-06-06 20:18:04 +0530
committerPradyun Gedam <pradyunsg@gmail.com>2018-06-06 20:18:04 +0530
commitbb6df11eae1ac2dd32c160e0be151037e8067a27 (patch)
tree17cd7e4f502e0cdb46aa87b0777b7f4c06b76dc4 /setup.py
parenta86e1495939815afc1ff0b3e5b29b50cca7dd874 (diff)
downloadpip-bb6df11eae1ac2dd32c160e0be151037e8067a27.tar.gz
Revert "Make it black."
This reverts commit a86e1495939815afc1ff0b3e5b29b50cca7dd874.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py29
1 files changed, 18 insertions, 11 deletions
diff --git a/setup.py b/setup.py
index aead59949..f52160a8f 100644
--- a/setup.py
+++ b/setup.py
@@ -12,14 +12,16 @@ here = os.path.abspath(os.path.dirname(__file__))
def read(*parts):
# intentionally *not* adding an encoding option to open, See:
# https://github.com/pypa/virtualenv/issues/201#issuecomment-3145690
- with codecs.open(os.path.join(here, *parts), "r") as fp:
+ with codecs.open(os.path.join(here, *parts), 'r') as fp:
return fp.read()
def find_version(*file_paths):
version_file = read(*file_paths)
version_match = re.search(
- r"^__version__ = ['\"]([^'\"]*)['\"]", version_file, re.M
+ r"^__version__ = ['\"]([^'\"]*)['\"]",
+ version_file,
+ re.M,
)
if version_match:
return version_match.group(1)
@@ -27,14 +29,15 @@ def find_version(*file_paths):
raise RuntimeError("Unable to find version string.")
-long_description = read("README.rst")
+long_description = read('README.rst')
setup(
name="pip",
version=find_version("src", "pip", "__init__.py"),
description="The PyPA recommended tool for installing Python packages.",
long_description=long_description,
- license="MIT",
+
+ license='MIT',
classifiers=[
"Development Status :: 5 - Production/Stable",
"Intended Audience :: Developers",
@@ -50,13 +53,16 @@ setup(
"Programming Language :: Python :: Implementation :: CPython",
"Programming Language :: Python :: Implementation :: PyPy",
],
- url="https://pip.pypa.io/",
- keywords="distutils easy_install egg setuptools wheel virtualenv",
- author="The pip developers",
- author_email="pypa-dev@groups.google.com",
+ url='https://pip.pypa.io/',
+ keywords='distutils easy_install egg setuptools wheel virtualenv',
+
+ author='The pip developers',
+ author_email='pypa-dev@groups.google.com',
+
package_dir={"": "src"},
packages=find_packages(
- where="src", exclude=["contrib", "docs", "tests*", "tasks"]
+ where="src",
+ exclude=["contrib", "docs", "tests*", "tasks"],
),
package_data={
"pip._vendor.certifi": ["*.pem"],
@@ -69,8 +75,9 @@ setup(
"pip=pip._internal:main",
"pip%s=pip._internal:main" % sys.version_info[:1],
"pip%s.%s=pip._internal:main" % sys.version_info[:2],
- ]
+ ],
},
+
zip_safe=False,
- python_requires=">=2.7,!=3.0.*,!=3.1.*,!=3.2.*,!=3.3.*",
+ python_requires='>=2.7,!=3.0.*,!=3.1.*,!=3.2.*,!=3.3.*',
)