summaryrefslogtreecommitdiff
path: root/pixman/Makefile.am
diff options
context:
space:
mode:
authorMizuki Asakura <ed6e117f@gmail.com>2016-04-17 20:16:12 +0900
committerMatt Turner <mattst88@gentoo.org>2021-09-17 17:03:02 +0000
commiteadb82866b0f6a326a61c36f60e5c2be8f7479af (patch)
treeb8301ac1012436a628ff0dfe38de2d03aef4d870 /pixman/Makefile.am
parent36001032b715ce5301e133fded5d06cbe4c87a43 (diff)
downloadpixman-eadb82866b0f6a326a61c36f60e5c2be8f7479af.tar.gz
added aarch64 bilinear implementations (ver.4.1)
Since aarch64 has different neon syntax from aarch32 and has no support for (older) arm-simd, there are no SIMD accelerations for pixman on aarch64. We need new implementations. This patch also contains Ben Avions's series of patches for aarch32 and now the benchmark results are fine to aarch64. Please find the result at the below ticket. Added: https://bugs.freedesktop.org/show_bug.cgi?id=94758 Signed-off-by: Mizuki Asakura <ed6e117f@gmail.com>
Diffstat (limited to 'pixman/Makefile.am')
-rw-r--r--pixman/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/pixman/Makefile.am b/pixman/Makefile.am
index 8f780a1..f05e2ad 100644
--- a/pixman/Makefile.am
+++ b/pixman/Makefile.am
@@ -96,6 +96,21 @@ libpixman_1_la_LIBADD += libpixman-arm-neon.la
ASM_CFLAGS_arm_neon=
endif
+# arm a64 neon code
+if USE_ARM_A64_NEON
+noinst_LTLIBRARIES += libpixman-arma64-neon.la
+libpixman_arma64_neon_la_SOURCES = \
+ pixman-arm-neon.c \
+ pixman-arm-common.h \
+ pixman-arma64-neon-asm.S \
+ pixman-arma64-neon-asm-bilinear.S \
+ pixman-arm-asm.h \
+ pixman-arma64-neon-asm.h
+libpixman_1_la_LIBADD += libpixman-arma64-neon.la
+
+ASM_CFLAGS_arm_neon=
+endif
+
# iwmmxt code
if USE_ARM_IWMMXT
libpixman_iwmmxt_la_SOURCES = pixman-mmx.c