summaryrefslogtreecommitdiff
path: root/demos/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'demos/meson.build')
-rw-r--r--demos/meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/demos/meson.build b/demos/meson.build
index 70f7c1f..3f9d306 100644
--- a/demos/meson.build
+++ b/demos/meson.build
@@ -18,6 +18,11 @@
# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
# SOFTWARE.
+extra_demo_cflags = []
+if cc.get_argument_syntax() == 'msvc'
+ extra_demo_cflags = ['-D_USE_MATH_DEFINES']
+endif
+
demos = [
'gradient-test',
'alpha-test',
@@ -51,6 +56,7 @@ if dep_gtk.found()
executable(
d,
[d + '.c', config_h, version_h],
+ c_args : extra_demo_cflags,
link_with : [libdemo, libtestutils],
dependencies : [dep_glib, dep_gtk, dep_openmp, idep_pixman],
)