summaryrefslogtreecommitdiff
path: root/docs/meson.build
diff options
context:
space:
mode:
authorJan Rybar <jrybar@redhat.com>2020-10-26 17:00:27 +0000
committerJan Rybar <jrybar@redhat.com>2020-10-26 17:00:27 +0000
commit957a015157fd359d9679540f664183e4b9492896 (patch)
tree41e7f5541d01e479e588cd3dd5a1769e1af0127a /docs/meson.build
parentff4c2144f0fb1325275887d9e254117fcd8a1b52 (diff)
downloadpolkit-957a015157fd359d9679540f664183e4b9492896.tar.gz
build: Port to meson build system
meson is a build system focused on speed an ease of use, which helps speeding up the software development. This patch adds meson support along autotools.
Diffstat (limited to 'docs/meson.build')
-rw-r--r--docs/meson.build29
1 files changed, 29 insertions, 0 deletions
diff --git a/docs/meson.build b/docs/meson.build
new file mode 100644
index 0000000..d4a0548
--- /dev/null
+++ b/docs/meson.build
@@ -0,0 +1,29 @@
+pk_api_docpath = pk_prefix / gnome.gtkdoc_html_dir(pk_api_name)
+
+enable_man = get_option('man')
+if enable_man
+ subdir('man')
+endif
+
+enable_gtk_doc = get_option('gtk_doc')
+if enable_gtk_doc
+ content_files += configure_file(
+ input: 'extensiondir.xml.in',
+ output: '@BASENAME@',
+ configuration: {'libdir': pk_prefix / pk_libdir},
+ )
+
+ content_files += configure_file(
+ input: 'version.xml.in',
+ output: '@BASENAME@',
+ configuration: {'VERSION': pk_version},
+ )
+
+ html_images = files(
+ 'polkit-architecture.png',
+ 'polkit-authentication-agent-example.png',
+ 'polkit-authentication-agent-example-wheel.png',
+ )
+
+ subdir('polkit')
+endif