summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorXi Ruoyao <xry111@mengyan1223.wang>2022-09-07 13:45:53 +0000
committerJan Rybar <jrybar@redhat.com>2022-09-07 13:45:53 +0000
commit91597f08929ddf1bc3a90a7122f9e23ea96d6e11 (patch)
tree508051ae599729d06d2681db3a763b2ed8e022a0 /meson.build
parent8e555982e5801e540925235beec42a2782911ea0 (diff)
downloadpolkit-91597f08929ddf1bc3a90a7122f9e23ea96d6e11.tar.gz
meson: support -Dos_type=lfs and /etc/lfs-release autodetection
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 8 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 8ffc2ce..8bab9ce 100644
--- a/meson.build
+++ b/meson.build
@@ -276,6 +276,7 @@ if os_type == ''
['debian', '/etc/debian_version'],
['gentoo', '/etc/gentoo-release'],
['pardus', '/etc/pardus-release'],
+ ['lfs', '/etc/lfs-release'],
]
foreach os_path: os_paths
@@ -306,6 +307,13 @@ if pam_include == ''
'PAM_FILE_INCLUDE_PASSWORD': 'system',
'PAM_FILE_INCLUDE_SESSION': 'system',
}
+ elif os_type == 'lfs'
+ pam_conf = {
+ 'PAM_FILE_INCLUDE_AUTH': 'system-auth',
+ 'PAM_FILE_INCLUDE_ACCOUNT': 'system-account',
+ 'PAM_FILE_INCLUDE_PASSWORD': 'system-password',
+ 'PAM_FILE_INCLUDE_SESSION': 'system-session',
+ }
#if ['redhat', 'gentoo', 'pardus'].contains(os_type)
else
pam_conf = {