summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorSimon McVittie <smcv@debian.org>2021-06-03 18:55:29 +0100
committerJan Rybar <jrybar@redhat.com>2021-09-07 16:03:38 +0000
commit9fa097f4dde92a0c1675400228b4cb965ed3e123 (patch)
tree7098ebce0f671b0b873485a28ba3e5b5f8114400 /meson.build
parent96c6fc83538fc28d1b3923b8be1eba2648f30e28 (diff)
downloadpolkit-9fa097f4dde92a0c1675400228b4cb965ed3e123.tar.gz
build: Remove redundant computation of dbus data directory
We were asking pkg-config "if I define ${datadir} to pk_prefix/pk_datadir, what would ${datadir} be?" but the answer is obviously always going to be pk_prefix/pk_datadir. Signed-off-by: Simon McVittie <smcv@debian.org>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 1 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 6a6799e..03a7683 100644
--- a/meson.build
+++ b/meson.build
@@ -136,8 +136,7 @@ assert(cc.has_function('XML_ParserCreate', dependencies: expat_dep), 'Can\'t fin
mozjs_dep = dependency('mozjs-78')
dbus_dep = dependency('dbus-1')
-dbus_confdir = dbus_dep.get_pkgconfig_variable('datadir', define_variable: ['datadir', pk_prefix / pk_datadir]) #changed from sysconfdir with respect to commit#8eada3836465838
-dbus_policydir = dbus_confdir / 'dbus-1/system.d'
+dbus_policydir = pk_prefix / pk_datadir / 'dbus-1/system.d'
dbus_system_bus_services_dir = dbus_dep.get_pkgconfig_variable('system_bus_services_dir', define_variable: ['datadir', pk_prefix / pk_datadir])
# check OS