summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2022-05-15 05:04:10 +0000
committerJan Rybar <jrybar@redhat.com>2022-07-14 12:50:49 +0000
commitb57deee8178190a7ecc75290fa13cf7daabc2c66 (patch)
tree83e43baf32a418b74492b123b4e437641fcdd31f /meson.build
parent827b0ddac5b1ef00a47fca4526fcf057bee5f1db (diff)
downloadpolkit-b57deee8178190a7ecc75290fa13cf7daabc2c66.tar.gz
Make netgroup support optional
On at least Linux/musl and Linux/uclibc, netgroup support is not available. PolKit fails to compile on these systems for that reason. This change makes netgroup support conditional on the presence of the setnetgrent(3) function which is required for the support to work. If that function is not available on the system, an error will be returned to the administrator if unix-netgroup: is specified in configuration. (sam: rebased for Meson and Duktape.) Closes: https://gitlab.freedesktop.org/polkit/polkit/-/issues/14 Closes: https://gitlab.freedesktop.org/polkit/polkit/-/issues/163 Closes: https://gitlab.freedesktop.org/polkit/polkit/-/merge_requests/52 Signed-off-by: A. Wilcox <AWilcox@Wilcox-Tech.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 908f0aa..66c4e9b 100644
--- a/meson.build
+++ b/meson.build
@@ -89,6 +89,7 @@ config_h.set('_GNU_SOURCE', true)
check_functions = [
'clearenv',
'fdatasync',
+ 'setnetgrent',
]
foreach func: check_functions