summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorSimon McVittie <smcv@debian.org>2021-06-03 19:23:13 +0100
committerSimon McVittie <smcv@collabora.com>2021-07-19 13:00:55 +0000
commite9aef13188593ebf06b9dc2d7de5d664c9790d6a (patch)
treed6c29cbf0b74e329a9ce0a807d3146f5c9c44ec6 /meson.build
parent6c8022392713955c5ae0061e22b50a16a1c2252a (diff)
downloadpolkit-e9aef13188593ebf06b9dc2d7de5d664c9790d6a.tar.gz
build: Make the directory for helper executables consistent with Autotools
The Autotools build system has been using /usr/lib/polkit-1 for several releases, even on distributions where the library directory is /usr/lib64 or /usr/lib/x86_64-linux-gnu, so it makes sense for Meson to do the same. This lets 32- and 64-bit polkit agents share a single helper executable. This might be superseded by polkit!63, which requests going back to using the libexecdir for these (like polkit 0.105 did), which would also make sense; but until that's decided, let's at least be consistent between our two build systems. Every time we change this, all programs that have already loaded libpolkit-agent into their address space need to be restarted, unless distributions provide compatibility symlinks. Signed-off-by: Simon McVittie <smcv@debian.org>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 3 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index bd4ec6b..81715b5 100644
--- a/meson.build
+++ b/meson.build
@@ -27,7 +27,8 @@ pk_sysconfdir = get_option('sysconfdir')
pk_pkgdatadir = pk_datadir / pk_api_name
pk_pkgincludedir = pk_includedir / pk_api_name
-pk_pkglibdir = pk_libdir / pk_api_name
+# note that this is always 'lib', not lib64 or lib/x86_64-linux-gnu
+pk_libprivdir = 'lib' / pk_api_name
pk_pkgsysconfdir = pk_sysconfdir / pk_api_name
pk_actiondir = pk_api_name / 'actions'
@@ -324,7 +325,7 @@ meson.add_install_script(
'meson_post_install.py',
get_option('bindir'),
pk_pkgdatadir,
- pk_pkglibdir,
+ pk_libprivdir,
pk_pkgsysconfdir,
polkitd_user,
)