summaryrefslogtreecommitdiff
path: root/src/examples/Makefile.am
diff options
context:
space:
mode:
authorDavid Zeuthen <davidz@redhat.com>2009-02-09 15:53:51 -0500
committerDavid Zeuthen <davidz@redhat.com>2009-02-09 15:53:51 -0500
commitb891d8a3245d364975cecb2289c442f54b2327c6 (patch)
tree7d500881e6c0098c23924888421aaf007162bf3c /src/examples/Makefile.am
parent21e21e97cd2b663ae96efe62c8f6cc69edbd1d3c (diff)
downloadpolkit-b891d8a3245d364975cecb2289c442f54b2327c6.tar.gz
add the ObtainAuthorization() method and use in for the 'polkit-1 run' command
Also add an example for this.
Diffstat (limited to 'src/examples/Makefile.am')
-rw-r--r--src/examples/Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/src/examples/Makefile.am b/src/examples/Makefile.am
index 1c40863..524e67b 100644
--- a/src/examples/Makefile.am
+++ b/src/examples/Makefile.am
@@ -15,7 +15,7 @@ INCLUDES = \
-D_REENTRANT \
$(NULL)
-noinst_PROGRAMS = cancel
+noinst_PROGRAMS = cancel cancelobtain
cancel_SOURCES = cancel.c
@@ -28,5 +28,16 @@ cancel_LDADD = \
$(top_builddir)/src/polkit/libpolkit-gobject-1.la \
$(NULL)
+cancelobtain_SOURCES = cancelobtain.c
+
+cancelobtain_CFLAGS = \
+ $(GLIB_CFLAGS) \
+ $(NULL)
+
+cancelobtain_LDADD = \
+ $(GLIB_LDADD) \
+ $(top_builddir)/src/polkit/libpolkit-gobject-1.la \
+ $(NULL)
+
clean-local :
rm -f *~