summaryrefslogtreecommitdiff
path: root/test/polkit/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test/polkit/meson.build')
-rw-r--r--test/polkit/meson.build27
1 files changed, 27 insertions, 0 deletions
diff --git a/test/polkit/meson.build b/test/polkit/meson.build
new file mode 100644
index 0000000..9c5254f
--- /dev/null
+++ b/test/polkit/meson.build
@@ -0,0 +1,27 @@
+test_units = [
+ 'polkitunixusertest',
+ 'polkitunixgrouptest',
+ 'polkitunixnetgrouptest',
+ 'polkitidentitytest',
+]
+
+c_flags = [
+ '-D_POLKIT_COMPILATION',
+ '-D_POLKIT_BACKEND_COMPILATION',
+]
+
+foreach test_unit: test_units
+ exe = executable(
+ test_unit,
+ test_unit + '.c',
+ dependencies: libpolkit_gobject_dep,
+ c_args: c_flags,
+ )
+
+ test(
+ test_unit,
+ exe,
+ env: test_env,
+ is_parallel: false,
+ )
+endforeach