summaryrefslogtreecommitdiff
path: root/test/polkitbackend/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/polkitbackend/Makefile.am')
-rw-r--r--test/polkitbackend/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/test/polkitbackend/Makefile.am b/test/polkitbackend/Makefile.am
index 53bfb2a..4b13256 100644
--- a/test/polkitbackend/Makefile.am
+++ b/test/polkitbackend/Makefile.am
@@ -33,16 +33,16 @@ TEST_PROGS =
# ----------------------------------------------------------------------------------------------------
-TEST_PROGS += polkitbackendjsauthoritytest
polkitbackendjsauthoritytest_SOURCES = test-polkitbackendjsauthority.c
# force C++ link via dummy C++ file, (see GNU automake manual section 8.3.5)
nodist_EXTRA_polkitbackendjsauthoritytest_SOURCES = dummy-force-cpp-link.cxx
+TESTS_ENVIRONMENT = TOP_BUILD_DIR="$(top_builddir)"
+TEST_PROGS += polkitbackendjsauthoritytest-wrapper.py
# ----------------------------------------------------------------------------------------------------
-noinst_PROGRAMS = $(TEST_PROGS)
-check_PROGRAMS = $(TEST_PROGS)
+noinst_PROGRAMS = polkitbackendjsauthoritytest
TESTS = $(TEST_PROGS)
clean-local :