summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndres Freund <andres@anarazel.de>2022-08-18 10:41:42 -0700
committerAndres Freund <andres@anarazel.de>2022-08-18 10:41:42 -0700
commit4ab53b647abffb911bea35662ca4b22d788c25d4 (patch)
tree5d2b0fab55c23d756624a06dc2ddf8c7a2f4587a /configure.ac
parent6566133c5f52771198aca07ed18f84519fac1be7 (diff)
downloadpostgresql-4ab53b647abffb911bea35662ca4b22d788c25d4.tar.gz
Don't add HAVE_LDAP_H HAVE_WINLDAP_H to pg_config.h
They're not referenced, so we don't need them in in pg_config.h. Reviewed-by: Peter Eisentraut <peter.eisentraut@enterprisedb.com> Discussion: http://postgr.es/m/e0c44fb2-8b66-a4b9-b274-7ed3a1a0ab74@enterprisedb.com
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 6 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 67cf317c3b..dd368290a6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1547,15 +1547,15 @@ fi
if test "$with_ldap" = yes ; then
if test "$PORTNAME" != "win32"; then
- AC_CHECK_HEADERS(ldap.h, [],
- [AC_MSG_ERROR([header file <ldap.h> is required for LDAP])])
+ AC_CHECK_HEADER(ldap.h, [],
+ [AC_MSG_ERROR([header file <ldap.h> is required for LDAP])])
PGAC_LDAP_SAFE
else
- AC_CHECK_HEADERS(winldap.h, [],
- [AC_MSG_ERROR([header file <winldap.h> is required for LDAP])],
- [AC_INCLUDES_DEFAULT
+ AC_CHECK_HEADER(winldap.h, [],
+ [AC_MSG_ERROR([header file <winldap.h> is required for LDAP])],
+ [AC_INCLUDES_DEFAULT
#include <windows.h>
- ])
+ ])
fi
fi